12

I am a mac user but I have installed the TeX Live distribution without the help of MacTeX. The directory /usr/texbin is missing and TeXShop or TeXworks won't compile.

I know that I can change the path to the bin in these applications, but I would prefer creating a /usr/texbin (is it a symbolic link?) similar to the one created by MacTeX.

PS : Why do I am in this situation ? I wanted to update my installation to 2013. So, I downloaded the big .iso file of the TeXLive distribution. But, TeXShop was still accessing the 2012 folder... So I removed this one, etc.

  • 3
    I ended up downloading MacTeX. I leave the question open; it might interest someone. As for me, I solved my problem. Thanks! – Colas Oct 9 '13 at 13:12
15

You can easily change the path for the TeX programs also with TeXShop and TeXworks; just make them point to /usr/local/texlive/2013/bin/x86_64-darwin; the drawback is that you need to change this at every installation. MacTeX does this for you by creating an infrastructure in /Library/TeX and making a symbolic link /usr/texbin that's managed by the installer or by the TeX distribution pane in the System Preferences.

If you don't want to download MacTeX and prefer to directly install TeX Live, you can create the symbolic link yourself by

sudo ln -s /usr/local/texlive/2013/bin/x86_64-darwin /usr/texbin

(change x86_64-darwin to universal-darwin if you don't have a 64 bit system); just remember to do

sudo rm /usr/texbin

as soon as you install a new release, before creating the symbolic link again.

1

Applicable only to El Capitan Final release and Later OS...

As @ChristopheDeTroyer mentioned, since El Capitan, symbolic links cannot be created because of the rootless mode. There are 2 ways to get rid of this and similar problems:

  1. Disable the rootless mode (this is how to do it) and then add the symbolic link using sudo ln -s /usr/local/texlive/2013/bin/x86_64-darwin /usr/texbin. You can re-enable the rootless mode if you want.
  2. Change each and every path of your editor to usr/local/texlive/XXXX/bin/x86_64-darwin, where XXXX is the version of your MacTex Distribution. For this problem, it would be either 2015 or 2016 as this workaround applies only to El Capitan and later Mac Oses. I use tex-studio and I just had to set the paths once and that's it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.