5

I'm making a thesis in danish, which means I use the packages:

\usepackage[utf8]{inputenc}
\usepackage[danish]{babel}

Now, I have split up my documents into chapters, and so far I have:

\begin{document}

\input{titlepage}

\input{abstract}

\chapter*{Dedication}
To mum and dad

\chapter*{Declaration}
I declare that..

\chapter*{Acknowledgements}
I want to thank ass...

\tableofcontents

\listoffigures

\listoftables

\chapter{Indledning}
\input{chapters/introduction}

\chapter{Ken Wilbers teoretiske bidrag}
\input{chapters/chapter02}

\chapter{Jan Tønnesvangs teoretiske bidrag}
\input{chapters/chapter03}

In my main.tex file. Now, I've been writing in danish in chapter02 and chapter03 for a while now, with no problems, regarding the ÆØÅ characters. But today I just wrote in the introduction.tex file, and when I use ÆØÅ I get the following error:

inputenc: Keyboard character used is undefined(inputenc) in inputencoding `utf8'. ...en Wilbers Kvadrantmodel og Jan Tnnesvang ø

This error comes a little different for every ÆØÅ character I use in the file.

And I have no idea how to fix it ? The introduction.tex file looks exactly as the chapter files. Only text, no packages and stuff. But only in that one, I get the error. And I have tried to remove every ÆØÅ in the text, and then it works. But if I just write one character, it gives me an error.

So, how do I fix this ? In my opinion there shouldn't be any difference on the chapter-tex files and the introduction-tex file. But maybe I'm missing something ?

Thanks in advance.

  • 2
    Most likely, introduction.tex got saved in the wrong encoding. How that happens, and how to fix it, depends a bit on what editor you use. – Harald Hanche-Olsen Oct 10 '13 at 13:43
  • I use TeXStudio. Could I just delete it, and the re-create a new file with the same name ? – Denver Dang Oct 10 '13 at 13:47
  • In most editors you can just open the file and then select which encoding to use and save it again. This avoids having to rewrite. By the way, you ought to be using \usepackage[T1]{fontenc} to get the most out of hyphenation. – Andrew Swann Oct 10 '13 at 13:50
  • Well, it did indeed work just to copy everything from the file, delete in, make a new, paste it, and save again :) Thanks for the help :) – Denver Dang Oct 10 '13 at 13:53
  • Good; problem solved, then. I suggest you create an answer saying this, then accept it, so this question doesn't hang around forever as an unanswered question. – Harald Hanche-Olsen Oct 10 '13 at 13:54
8

The problem occurs if the file introduction.tex has been saved in the wrong encoding. Copying and pasting into a new file, or opening the file in and editing, setting the encoding and saving again, will fix this.

When writing in a language such as Danish it is additionally advisible to use

\usepackage[T1]{fontenc}

to allow hyphenation in words containing characters such as æ, ø and å.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.