1

This question already has an answer here:

I'm completely new here, and trying LaTeX to write my PhD dissertation (in the humanities, mind you!). I have to write in several languages, and especially French. It is therefore much easier to type the French characters directly on the keyboard. I have a mac with OS 10.8.5. I used the tip given here on the Tex stack exchange (\usepackage[applemac]{inputenc}) and it worked really fine. But, now it suddenly does not work any more without me touching anything when I run it in PDF. I set the following in my configuration:

\usepackage[applemac]{inputenc}             

\usepackage{etoolbox}
\usepackage{fontspec}
 \usepackage{polyglossia}       

 \setdefaultlanguage[british,ordinalmonthday=true]{english}
 \setotherlanguage[spelling=old,latesthyphen=true,babelshorthands=true]{german}
 \setotherlanguage{french}
 \setotherlanguage{italian}
 \usepackage{xspace}

\usepackage[style=british,autostyle=true,strict=true,english=british,autopunct=true,parthreshold=true,german=guillemets]{csquotes}
\setquotestyle{british}
\SetBlockThreshold{3} 

marked as duplicate by egreg, Joseph Wright Jan 2 '16 at 22:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 9
    Never use inputenc with xetex or luatex (which you must be using as you use fontspec Just make sure that you save your file in utf-8 and the characters will work. – David Carlisle Oct 10 '13 at 17:39
  • 1
    Welcome to TeX.SE! The code snippets you've provided don't generate the problems you're describing. Please edit your code to make into an MWE (minimum working example) that illustrates the points you're trying to fix. Also, please indicate which editor(s) you use. – Mico Oct 10 '13 at 17:42
  • @DavidCarlisle why don't you write an answer up? :) – Mario S. E. Oct 10 '13 at 21:18
  • @MarioS.E. I was looking for a duplicate question – David Carlisle Oct 10 '13 at 21:38
  • Thank you very much. Getting rid of the inputenc command has fixed the issue. – Frank Ejby Poulsen Oct 17 '13 at 10:41

Browse other questions tagged or ask your own question.