I'm trying to get pictures with pstricks working in my thesis. I tried to run some code from LatexDraw but when this didn't work I tried to get the minimal example from here to run: PSTricks picture not compiling with pdfLaTeX

If I only put this code in a file an run pdflatex --shell-escape test.tex it works as expected. However if I copy it into my thesis it fails with this error message:

  auto-pst-pdf: Auxiliary LaTeX compilation
  This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
  entering extended mode
  This is dvips(k) 5.992 Copyright 2012 Radical Eye Software (www.radicaleye.com)
  ' TeX output 2013.10.10:1955' -> gliederung-autopp.ps
  </usr/local/texlive/2012/texmf/dvips/base/special.pro>. [1]
  Error: /typecheck in --div--
  Operand stack:
     1   0   0.0   -0.0478856   a   65781.8
  Execution stack:
     %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1894   1   3   %oparray_pop   1893   1   3   %oparray_pop   1877   1   3   %oparray_pop   1771   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   --nostringval--   4   --nostringval--   %repeat_continue   --nostringval--
  Dictionary stack:
     --dict:1158/1684(ro)(G)--   --dict:0/20(G)--   --dict:117/200(L)--   --dict:99/300(L)--
  Current allocation mode is local
  Last OS error: 2
  Current file position is 84788
  GPL Ghostscript 9.05: Unrecoverable error, exit code 1
  PDFCROP 1.38, 2012/11/02 - Copyright (c) 2002-2012 by Heiko Oberdiek.

  !!! Warning: Empty Bounding Box is returned by Ghostscript!
  !!!   Page 1: 0 0 0 0
  !!! Either there is a problem with the page or with Ghostscript.
  !!! Recovery is tried by embedding the page in its original size.

Anyone got some hints on what to do? I'm adding my preamble in case there should be something odd in it.







closed as unclear what you're asking by Christoph, Joseph Wright Mar 1 '14 at 21:34

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 5
    Consider gradually deleting parts of the preamble until the problem disappears. Then you'll know the offending lines. If you can't solve the problem then, you will be able to edit the question to provide a minimal (non)working example. – Ethan Bolker Oct 10 '13 at 18:19
  • 1
    your PSTricks example is wrong: Error: /typecheck in --div-- a 65781.8 it will devide a by 65781.8 but a is not known. Make a complete example which shows the code of the problem! – user2478 Oct 10 '13 at 18:26
  • 3
    Welcome to the site! Before you start deleting content, be sure to make a copy first :) – cmhughes Oct 10 '13 at 19:20

Browse other questions tagged or ask your own question.