I tried to use biblatex for the first time, instead of BibTeX, which was fine, however LaTeX is obviously unable to insert the .bib file because the warning messages stay the same if I intentionally do not try to insert a .bib-file. Although I have been trying for several days, I could not find a solution to the problem.

\usepackage[backend=biber, style=apa]{biblatex}

  author = {Sample, Susan G},
  title = {Military Buildups, War, and Realpolitik A Multivariate Model},
  journal = {Journal of Conflict Resolution},
  year = {1998},
  volume = {42},
  pages = {156--175},
  publisher = {Sage Publications}
%\bibliography{Bibliographie} % Did not help either
%\bibliography{C:/Users/<Musterpfad>/Bibliographie} % Did not help either

Test \cite{Sample1998}


The output looks like this "Test [Sample1998] " I got no error but several warning messages:

BibTeX> WARN - Warning: Found biblatex control file 2.5, expected version 2.3 % as well as
LaTeX Warning: Citation 'Sample1998' on page 1 undefined on input line 23.
LaTeX Warning: Empty bibliography on input line 25.   
LaTeX Warning: There were undefined references.
Package biblatex Warning: Please (re)run Biber on the file:
(biblatex)                Test
(biblatex)                and rerun LaTeX afterwards.

Re-running LaTeX, even several times, did not change anything. Moreover the .bbl file is empty.

I am using MiKTeX 2.9 32bit version (early on I have used the 64bit - there was no difference) and TeXnicCenter 2.02, 32bit. In the latter one I have changed the "path to the BibTeX executable" from "C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\bibtex.exe" to "C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\biber.exe" I have the feeling that I should change something within the TeXnicCenter settings, therefore I attached my output profile.texniccenter output profile

  • 5
    Warning: Found biblatex control file 2.5, expected version 2.3 states the problem. The version of biblatex and Biber do not match. Try deleting the temporary files (.aux, .bbl etc. pp.); if that does not help, update your MiKTeX distribution. – moewe Oct 10 '13 at 19:03
  • 1
    Thank you for the fast reply. Deleting the temporary files, installing the newest biber version or updating MikTex did not help either. I reinstalled Texniccenter and miktex several times, always using the newest version of the programms. However unsuccessful. What "Command line arguments to pass to BibTeX" have you? – Paul Oct 11 '13 at 11:16
  • Mhh, I don't use TeXnicCenter. The problem should not be related to TeXnicCenter; did you actually update MiKTeX or did you only re-install it? Try the following: Using the command line's cd command, navigate into the folder the .tex file is contained in; let's assume the .tex file is called test.tex, while the .bib file is called test.bib; invoke pdflatex test, then biber test and then pdflatex test. – moewe Oct 11 '13 at 12:52
  • Both: Reinstalling and updating it. Now I updated everything and the message "Warning: Found biblatex control file 2.5, expected version 2.3" disappeared (I checked it in the .log file, too). However the other four warning massages reported above remained. I am sorry, but I do not understand your suggestion, what is the "command line's cd command"?. I am compiling my .tex document several times like I did it as I was using bibtex but nothing changes. – Paul Oct 11 '13 at 19:59
  • When I said "command line's cd command" I intended to say: Open a command line (on Windows that is cmd.exe) and use cd to navigate to the proper folder. The idea was: Try compiling the document not with TeXnicCenter, but manually. So we can pinpoint whether this is actually a TeXnicCenter problem. – moewe Oct 12 '13 at 7:01

I ran into the exact same problem using Texmaker. After re-installing the current MikTex version, I figured that the Biber package was still not updated. Manually downloading the current Biber version (http://biblatex-biber.sourceforge.net/) and replacing the old Biber.exe in the according MikTex file structure solved all problems for me.

  • got the same problem, your solution fixed this, thanx a lot for time saving. – Max Dec 15 '13 at 10:45

I'm using TeXnicCenter with biber an I use the following (a little bit different) configuration:

enter image description here

See the arguments to the LaTeX compiler (%pm). My call to biber instead of bibtex is the same.

If that does not help, your computer has a problem with your installation. Please delete your old installation (TeXnicCenter and MiKTeX), then reboot your computer. Download the current MiKTeX, install it (I prefer the complete version), then download the current TeXnicCenter and install it. Now create a new profile for biber and it should compile (I have -synctex=-1 because I use SumatraPdf).

  • Thank you for the hint. I have tried both of your solutions. Unfortunately none of it worked. I can use all other Latex feature so I do not think it is a problem with pdflatex. Maybe it is a problem with Miktex 2.9 and Windows 8? But I think it is unlikely, since I have tried using both, the 32 and 64-bit Miktex version (my computer is running a 64-bit Windows 8). – Paul Oct 14 '13 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.