Here's a minimal example:

% File: test.tex




(1) Rendered as link (red). Normal behaviour.


(2) Rendered as citation (cyan). File extension .pdf appended.



After running pdfLaTeX on this minimal example, the link in (2) is rendered as a citation with a .pdf extension appended. Mousing over it shows 'Go to file "doc.pdf"' (when viewed with evince).

How can I get it rendered as a link and also get rid of the added .pdf extension?

I'm using TeXLive 2013 and pdfTeX version is 3.1415926-2.5-1.40.14.

  • 1
    Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. Oct 12 '13 at 14:10
  • Are you trying to link a file without extension? Oct 12 '13 at 14:29
  • Yes, a typical case is to link to a README file in the same directory as the pdf document.
    – stl
    Oct 13 '13 at 5:57
  • Thanks for the formatting information! I am a user of markdown myself but was overwhelmed when SX presented me with a html editor text area. :-) Maybe it should point people to the formatting information.
    – stl
    Oct 13 '13 at 6:11

hyperref interprets \href{abc}{...} as file link with an extension, that can be configured by option extension. If the protocol is specified, then the result is a URL link:

  • \href{http:abc}{...} points to http:abc but not abc. \href{file://abc}{abc} won't work either. Setting extension={} gives a link to abc. but not abc. :-(
    – stl
    Oct 13 '13 at 6:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.