4

I'm trying to get Hebrew to work for my LaTeX/LyX on Ubuntu 12.04. I have TeX Live 2012 installed and the Hebrew works for that. Then I followed the instructions for installing LyX + Hebrew support, this requires installing the culmus LaTeX package. I've gotten this to install as well, however for some reason LaTeX doesn't recognize the file culmus.sty.

The path for the file is

/usr/share/texmf-texlive/tex/latex/culmus/culmus.sty

I've also copied the file to my ~/texmf directory. I've run both mktexlsr and texhash, but when I try to compile a LaTeX file with \usepackage{culmus}, I get

ERROR: LaTeX Error: File culmus.sty not found.

In addition, when I save the file in the ~/texmf directory and compile, I no longer get that error, instead I get:

ERROR: I can't find file `jerus10'.

--- TeX said ---
<*> ...=ljfour; mag:=1; nonstopmode; input jerus10

Please type another input file name
! Emergency stop.
<*> ...=ljfour; mag:=1; nonstopmode; input jerus10

Transcript written on mfput.log.
grep: jerus10.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input jerus10' failed to make jerus10.tfm.
kpathsea: Appending font creation commands to missfont.log.

! Font LHE/cmr/m/n/10=jerus10 at 10.0pt not loadable: Metric (TFM) file not found.
<to be read again> 
                   relax 
l.2 \select@language{hebrew}

The file I'm using as a test goes as follows:

\documentclass[english,hebrew]{article}
\usepackage[utf8x]{inputenc}
\usepackage{babel}
%\usepackage{culmus}

\begin{document}
\selectlanguage{hebrew}
שלום לכל העולם!
\end{document}

Any help would be very appreciated!

  • 1
    Try doing Tools > Reconfigure. After that you should get the same error you get at the command line. Note that I can compile your file just fine. I have Hebrew support from the IvriTeX fonts. Note that you could have installed TeX Live and all extra files needed to run all of LyX's templates and examples (including the Hebrew examples) with the following: github.com/scottkosty/install-tl-ubuntu Note that you need to run install-tl-ubuntu with the --hebrew option; you might want --more-tex. I only recommend this if you have a virtual machine or don't mind reinstalling Ubuntu. – scottkosty Oct 13 '13 at 17:33
  • 2
    Another option is to use XeTeX. I specify how to do that on Ubuntu in LyX here: tex.stackexchange.com/questions/137046/… – scottkosty Oct 13 '13 at 17:33
  • 1
    And of course you should update to TL2013 and install vanilla TL. :-) – Martin Schröder Oct 13 '13 at 20:43
  • I don't think installing vanilla TL would solve anything since the problem seems to be that the culmus-latex fonts are broken. – user38196 Oct 22 '13 at 21:03
  • I've just made a clean install of 13.10 and tried again. No luck. I've tried to install ivritex but Ubuntu refuses to install it, claiming an unsolvable dependency issue. So that route doesn't seem to work. However, I've tried going the XeTex route and this seems to do the job. Thanks! – user38196 Oct 22 '13 at 21:05
1

There is a bug in Ubuntu's (and Debian's) version of updmap, a workaround is available in http://www.guyrutenberg.com/2012/04/20/installing-culmus-latex-on-ubuntu-11-10/

(Discalimer: I maintain the culmus-latex package)

0

I had a similar but not exactly the same problem as yours:

How do I add Hebrew support to TeXLive on Windows (with pdfTeX+babel)?

similar in that Culmus fonts were not being used and TeXLive was looking for the Jerusalem font's files.

I managed to work around the problem, see if that doesn't work for you, adapting the filenames and/or paths to a Linux setting.

If it does work for you, I'll write it up here more nicely...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.