I made a foolish choice to play around with fonts a few days ago, and haven't escaped since. After getting very kind and useful help here yesterday, I decided to follow the advice given, and change to use EBGaramond from the LaTeX Font Catalogue. This, however, has proved problematic.

I tried to follow the instructions given here as best I could - below is the sequence of events, using the following code as a MWE:



First of all, I used kpsewhich --var-value TEXMFLOCAL to determine obtain the value of /usr/local/share/texmf, to which I moved the unzipped ebgaramond folder (I had to use sudo mv to do so). I then applied sudo texhash, which gave the output:

texhash: Updating /usr/local/share/texmf/ls-R... 
texhash: Updating /var/lib/texmf/ls-R-TEXLIVEMAIN... 
texhash: Updating /var/lib/texmf/ls-R-TEXLIVEDIST... 
texhash: Updating /var/lib/texmf/ls-R-TEXMFMAIN... 
texhash: Updating /var/lib/texmf/ls-R... 
texhash: Done.

and then sudo updmap-sys --enable Map=EBGaramond.map, which produced

updmap: resetting $HOME value (was /home/philip) to root's actual home (/root).
updmap is using the following updmap.cfg files (in precedence order):
Creating new config file /etc/texmf/web2c/updmap.cfg
dvips output dir: "/var/lib/texmf/fonts/map/dvips/updmap"
pdftex output dir: "/var/lib/texmf/fonts/map/pdftex/updmap"
dvipdfmx output dir: "/var/lib/texmf/fonts/map/dvipdfmx/updmap"
pxdvi output dir: "/var/lib/texmf/fonts/map/pxdvi/updmap"

ERROR:  The following map file(s) couldn't be found:
    EBGaramond.map (in /etc/texmf/web2c/updmap.cfg)

    Did you run mktexlsr?

    You can disable non-existent map entries using the option

On the basis of that output, I ran sudo mktexlsr, followed by sudo updmap-sys --enable Map=EBGaramond.map.

This, however, produced an error when I ran pdfLaTeX, saying ebgaramond.sty could not be found. I thus then moved ebgaramond to ~/texmf/tex/latex/, and reran sudo texhash. Now, however, the compilation fails with the error

! I can't find file `EBGaramond12-Regular-osf-t1'.

I did try putting in \usepackage{fontspec} and \setmainfont{ebgaramond}, but that threw up another series of errors, and I'd really rather not go down the XeTeX route.

I'll admit, I have been lurching through the problems, but can anyone please give me some tips on this? The phrasing in the README suggests it's a simple process, but I'm still having troubles.

Thanks in advance for any advice.

  • you don't need fontspec or the commands that follow with ebgaramond package. You don't need the fontenc package either. Try this, Type in your terminal tlmgr show ebgaramond and see if it's installed. If not, it's always a good idea to try to copy the whole folder and its contents (assuming it is unzipped of course) into say texmf-dist/tex/latex , although the local directory is recommended most of the times, there are times when you have no option but to use the texmf directory like you just did. – doed Oct 14 '13 at 3:54
  • 1
    A distribution like Ubuntu is meant to simplify things, not to complicate them. Install the full TUG TeX Live rather than the Debian one; it just requires a (not really so) complicated session and you'll have EB Garamond out of the box (and not only that). – egreg Oct 14 '13 at 7:35
  • Exactly! and then install TeX Live by ./install-tl --gui wizard (if a message says Cannot load Tk then sudo apt-get install perl-tk. Remember either way (whether in the wizard mode or text mode) to edit the folder where you want it. Unless the /usr folder has enough space, I suggest you to use another directory. Once the installation finishes, remember to copy the last lines that will say something like Most importantly, add /PATH/TO/DIRECTORY to your PATH for current and future sessions. Copy that Then open .bashrc and add PATH=/PATH/TO/DIRECTORY:$PATH, save and restart. – doed Oct 14 '13 at 8:43
  • Thanks to both for the advice - I did follow it, and after an installation plagued with a dodgy internet connection, I managed to install it without much hassle. As a slight word of warning: I did have a small problem with one of the files, but the fix is presented tex.stackexchange.com/questions/135781/… – Phil G Oct 19 '13 at 14:19

Solved by uninstalling the Ubuntu package, and installing the full package directly. Slight problem with installation solved according to Are itemize and EBGaramond compatible?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.