1

I am trying to use TikzEdt tool to generate some graphs....It was working very nicelly, until I tried the extended mode, and from that instance, it is reporting an error. Here is the preamble

\documentclass[fleqn]{article}
\usepackage{tikz,amsmath, amssymb,bm,color}
\usepackage[margin=0cm,nohead]{geometry}
\usepackage[active,tightpage]{preview}
\usetikzlibrary{automata,positioning}
\usetikzlibrary{shapes,arrows}
% needed for BB
\usetikzlibrary{calc}   
%% Begin Added by me
\usepackage{pdfpages}       %To be able to insert PDF pages   
\usepackage{pgfplots}    
%% End of added by me
\PreviewEnvironment{tikzpicture}

and here is a very basic code

% Define block styles    
\tikzstyle{line} = [draw, -latex']  

\begin{tikzpicture}[node distance = 2cm,auto]
    % Place nodes
    \node [draw,rounded corners] (node1) {node1};

\end{tikzpicture}

I tried (Re-)Generate Precompiled headers and this is what I get:

Generating precompiled header: pdflatex -ini -jobname="temp_header" "&pdflatex temp_header.tex\dump"
Compilation of pre-compiled header failed with exit code 1. Compilation of main document stopped. Check that all necessary packages are installed and that the pre-compiled header code (in the settings) has no errors!

A file named temp_header.auxlock is generated containing one single line \def \tikzexternallocked {0} Can any one please suggest some help?

7
  • And how did you try to enter extended mode in tikzedt?. I think you are trying to overuse tikzedt. It is meant primarily to draw tikz pictures and not for writing articles. Please try some other LaTeX editors.
    – user11232
    Commented Oct 15, 2013 at 7:17
  • 1
    Your additions work fine for me. However you can try with (Re-)Generate precompiled headers in Compilation menu.
    – user11232
    Commented Oct 15, 2013 at 7:51
  • @HarishKumar, I am not using it for documents, but only for graphs....The regeneration also gave an error (see thread update)...As for your question, with a given document, the number of points exceeded the limit, so, I've read somewhere that one has to enter the extended mode. Didn't work, so I had to reduce the number of points..but now, nothing is working. Commented Oct 15, 2013 at 9:03
  • Instead of trying to modify the precompiled header, you can use standalone option of tikzedt. In the side bar,look for standalone` and in that standalone document.
    – user11232
    Commented Oct 15, 2013 at 9:44
  • @HarishKumar can you please include a snapshot? my TikzEdt seems not to have the standalone version... Commented Oct 15, 2013 at 10:17

1 Answer 1

3

I figured out the solution with the help of a friend. in the directory ...C:\Users\username\AppData\Roaming\TikzEdt\TikzEdt\0.2.3.0 open the file temp_header.tex and make sure it maches the Pre-amble in TikzEdt. The directory and the file are both hidden, so you have to check that hidden files are displayed.

1
  • I didn't have your problem but looking at the file temp_header.tex I solved mine too. I've also found some other useful files: TE_temp_previewNNNNN.tex, .log, etc. (where NNNNN is the current process number) in C:\Users\username\AppData\Local\Temp.
    – CarLaTeX
    Commented May 24, 2016 at 4:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .