1

I'm aware there's a lot of questions regarding using eps files as graphics in pdfLaTeX, and have tried many 'fixes'/'get arounds' based on answers I've read on this forum (amongst others), but still can't get it to work.

I'm using Kile 2.1.0 on Ubuntu 12.04 LTS, having recently come from using TeXShop on a Mac.

I've read that in order to get Kile to compile my .tex file using PdfLaTeX I need to insert:

\usepackage{epstopdf}

in the preamble, which I have, but it still doesn't work. For example in a test .tex file I have included \usepackage{epstopdf} in the preamble, and then in the body written:

\begin{figure}[h!]
\begin{center}
\includegraphics[scale = 0.7]{pic1.eps}
\caption{\textit{A graphic.}}
\label{Label1}
\end{center}
\end{figure}

Upon running PDFLaTeX in Kile I get:

! Package pdftex.def Error: File `pic1-eps-converted-to.pdf' not found.

Which would suggest to me that epstopdf is doing SOMETHING, maybe putting the converted eps file somewhere silly?

Thanks in advance, Olie

  • Welcome to TeX.SX! Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document} – susis strolch Oct 15 '13 at 21:36
  • Did you used the option --shell-escape, when you call PDFLATEX, graphics to automatically convert your eps into a pdf? – susis strolch Oct 15 '13 at 21:40
  • You can use a converter like manpages.ubuntu.com/manpages/hardy/man1/epstopdf.1.html to convert all your eps files into pdfs and use them. – susis strolch Oct 15 '13 at 21:45
  • Hi, I've tried putting the option --shell-escape in by going to settings>configure kile>build>PDFLaTeX, and adding that line of code in the options field, but it still spits out the same error when I hit PDFLaTeX - any ideas? I'd really prefer not to have to convert all graphics beforehand using a separate converter if at all possible.. Thanks for your help. – user38328 Oct 16 '13 at 10:09
  • Open the Terminal, and type epstopdf to see if this program has been installed. I think you did not install it correctly. – Ch'en Meng Nov 29 '13 at 2:21
3

without the option --shell-escape it can't run external programs. Add it to Kile at `Settings->Configure Kile-> Build:

enter image description here

then the following should work:

\listfiles
\documentclass{article}
\usepackage{graphicx}
%\usepackage{epstopdf}
\begin{document}

\includegraphics[width=0.8\linewidth]{/tmp/titel2.eps}

\end{document}

epstopdf is loaded by default:

 *File List*
 article.cls    2007/10/19 v1.4h Standard LaTeX document class
  size10.clo    2007/10/19 v1.4h Standard LaTeX file (size option)
graphicx.sty    1999/02/16 v1.0f Enhanced LaTeX Graphics (DPC,SPQR)
  keyval.sty    1999/03/16 v1.13 key=value parser (DPC)
graphics.sty    2009/02/05 v1.0o Standard LaTeX Graphics (DPC,SPQR)
    trig.sty    1999/03/16 v1.09 sin cos tan (DPC)
graphics.cfg    2010/04/23 v1.9 graphics configuration of TeX Live
  pdftex.def    2011/05/27 v0.06d Graphics/color for pdfTeX
infwarerr.sty    2010/04/08 v1.3 Providing info/warning/error messages (HO)
 ltxcmds.sty    2011/11/09 v1.22 LaTeX kernel commands for general use (HO)
supp-pdf.mkii
pdftexcmds.sty    2011/11/29 v0.20 Utility functions of pdfTeX for LuaTeX (HO)
ifluatex.sty    2010/03/01 v1.3 Provides the ifluatex switch (HO)
   ifpdf.sty    2011/01/30 v2.3 Provides the ifpdf switch (HO)
epstopdf-base.sty    2010/02/09 v2.5 Base part for package epstopdf
  grfext.sty    2010/08/19 v1.1 Manage graphics extensions (HO)
kvdefinekeys.sty    2011/04/07 v1.3 Define keys (HO)
kvoptions.sty    2011/06/30 v3.11 Key value format for package options (HO)
kvsetkeys.sty    2012/04/25 v1.16 Key value parser (HO)
etexcmds.sty    2011/02/16 v1.5 Avoid name clashes with e-TeX commands (HO)
epstopdf-sys.cfg    2010/07/13 v1.3 Configuration of (r)epstopdf for TeX Live
/tmp/titel2-eps-converted-to.pdf
 ***********

You can test, if epstopdf.sty is installed. Run in a terminal:

kpsewhich epstopdf.sty

and it should report the location of the file:

voss@shania:~> kpsewhich epstopdf.sty
/usr/local/texlive/2013/texmf-dist/tex/latex/oberdiek/epstopdf.sty

If it outputs nothing then you have to install that package.

  • You don't need to add --write-enabled with recent versions of TeX Live as a restricted write is enabled by default now. Since the OP may be using Ubuntu's distribution of TeX, however, it might be necessary in that case. – cfr Dec 29 '13 at 15:49
  • sure, but it doesn't hurt if someone has an own texmf.cnf without an enabled epstopdf – user2478 Dec 29 '13 at 16:36
  • Well it hurts in the sense that it opens the system to security vulnerabilities quite unnecessarily. By default --shell-restricted is enabled. Since this is sufficient for epstopdf, it would be better to recommend this in case the OP is on a system where it is not default rather than recommending they enable unrestricted write globally - especially if you are setting it in the preferences of the editor, which are liable to remain in place. – cfr Dec 29 '13 at 21:10
  • it can only open it to what is defined in texmf.cnf! – user2478 Dec 29 '13 at 21:13
  • That's true of --shell-restricted. It is not true of --shell-escape that I know of. Are you sure --shell-escape is now equivalent to --shell-restricted? See tex.stackexchange.com/questions/65176/…. Is the information in the accepted answer there now obsolete? – cfr Dec 29 '13 at 21:17
1

I can't test this as you don't give a MWE and I don't have an .eps to hand. However, I suspect that you need to include

\epstopdfsetup{suffix=.generated,prefersuffix=true}

in your preamble to tell the graphics package how to convert your eps images.

So you'd use something like:

\documentclass{article}

\usepackage[pdftex]{graphicx}
\usepackage{epstopdf}
\epstopdfsetup{suffix=.generated,prefersuffix=true}

\begin{document}

\begin{figure}[h!]

\begin{center}

\includegraphics[scale = 0.7]{pic1.eps}
\caption{\textit{A graphic.}}
\label{Label1}

\end{center}

\end{figure}

\end{document}

Not having an eps to hand, though, I can't test this easily.

EDIT: Actually, I suspect from the error that you have such a rule but didn't include it in your question. In that case, do you have the programme epstopdf which you need to do the conversion? Perhaps this is not installed or is not being found for some reason. It should be part of your core TeX installation, though...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.