2

I'm writing a report in latex and I included an appendix in my document. When I typeset, the title "Appendix" appears on a page by itself. I want this "Appendix" title to be on the same page as my appendix content. What should I do?

\documentclass[12pt, oneside]{report}
\usepackage[left=1in, top=1in, bottom=1in, right=1in]{geometry}
\geometry{letterpaper}
\usepackage{setspace}
\usepackage{graphicx}
\usepackage{indentfirst}
\usepackage{abstract}
\usepackage{biblatex}
\usepackage[toc,page]{appendix}

\begin{document}

\tableofcontents
\thispagestyle{empty}

\chapter{Introduction}

\newpage
\addcontentsline{toc}{chapter}{Bibliography}
\nocite{Lec2}
\printbibliography

\begin{appendices}
\chapter{stuff} \label{App: AppendixA}
\begin{figure}[h]
\centering
\includegraphics[scale=0.62]{stuff}
\end{figure}

\chapter{stuff} \label{App: AppendixB}
\begin{figure}[h]
\centering
\includegraphics[scale=0.75]{stuff}
\end{figure}
\end{appendices}

\end{document}
6
  • 2
    If you remove the option page when loading appendix the page with "Appendices" is not shown. Do you really want a page starting with "Appendices" title and then "Appendix A" in the same page? – karlkoeller Oct 16 '13 at 19:05
  • You could just use \addtocounter{page}{-1} and remove the page manually. – John Kormylo Oct 22 '13 at 19:37
  • @karlkoeller Wanna convert your comment into a short answer? – Johannes_B Feb 15 '15 at 18:48
  • @Johannes_B My comment doesn't answer the question... – karlkoeller Feb 15 '15 at 18:54
  • @karlkoeller It was the best bet, i went for it. Close as unclear? – Johannes_B Feb 15 '15 at 18:55
3

I would suggest to simply remove the page option when loading appendix so that the page with "Appendices" is not shown.

But if you really want to have the "Appendices" title to be on the same page as your appendix contents, here is a way (I don't recommend to do it, of course).

Add the following lines just after \begin{appendices}

\clearpage
\begingroup
\let\clearpage\relax
\begin{center}
  \Huge\bfseries\appendixpagename
\end{center}
\chapter{stuff} \label{App: AppendixA}
\endgroup

and remove the page option when loading appendix.

MWE:

\documentclass[12pt, oneside]{report}
\usepackage[left=1in, top=1in, bottom=1in, right=1in]{geometry}
\geometry{letterpaper}
\usepackage{setspace}
\usepackage[demo]{graphicx}
\usepackage{indentfirst}
\usepackage{abstract}
\usepackage[toc]{appendix}

\begin{document}

\tableofcontents
\thispagestyle{empty}

\chapter{Introduction}

\begin{appendices}
\clearpage
\begingroup
\let\clearpage\relax
\begin{center}
  \Huge\bfseries\appendixpagename
\end{center}
\chapter{stuff} \label{App: AppendixA}
\endgroup

\begin{figure}[h]
\centering
\includegraphics[scale=0.62]{stuff}
\end{figure}

\chapter{stuff} \label{App: AppendixB}
\begin{figure}[h]
\centering
\includegraphics[scale=0.75]{stuff}
\end{figure}
\end{appendices}

\end{document} 

Output

enter image description here

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.