I'm currently learning how to use beamer, and I'm struggling with the miniframe command: Some (not even all) of my subsection dots align vertically, which is really anoying though it takes way too many space that way.

I don't know if it's the default setting of this command or if I'm doing anything wrong, but I can't find anyone talking about that issue (maybe I've not been looking hard enough, if so, I apology).

here's me code, it's so simple I hardly see how this can help at all but here you go:


Thank you for your time :)

  • Welcome to TeX.SX! Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – Herr K.
    Commented Oct 16, 2013 at 20:48
  • You might be looking for the outer theme smoothbars. It does the same as miniframes but keeps all dots in one line. Commented Oct 16, 2013 at 21:02

1 Answer 1


You are looking for the beamer option compress:

Some navigation bars can be “compressed” using the following option:


Tries to make all navigation bars as small as possible. For example, all small frame representations in the navigation bars for a single section are shown alongside each other. Normally, the representations for different subsections are shown in different lines. Furthermore, section and subsection navigations are compressed into one line.


\section{Section 1}
\subsection{Subsection 1}
\subsection{Subsection 2}
\section{Section 2}
\subsection{Subsection 1}
\subsection{Subsection 2}

headline for outer theme miniframes, using the compress option

  • 1
    Okay, thanks again. I'm glad I came over here, otherwise I could have searched in vain for hours only to get depressed when realizing the solution was this simple !
    – Rhino Vert
    Commented Oct 18, 2013 at 20:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .