5

When I compile my thesis the following error pops up:

Underfull \hbox (badness 1264) in paragraph at lines 61--61
[]\T1/ppl/m/n/12 ^^U^^U^^U.^^P  Naples 2008, or, the Waste Land: Trash, Citizenship, and an Ethic of
[106]
! Missing $ inserted.
<inserted text> 
            $
l.61 

This happens in latexmk, or in pdflatex after I run biber. Other posters reporting the same error often nail it down to an underscore in the bibtex entry, but this is clearly not the case here:

@ARTICLE{iovino2009naples,
  author = {Iovino, Serenella},
  title = {Naples 2008, or, the Waste Land: Trash, Citizenship, and an Ethic of Narration},
  journaltitle = {Neohelicon},
  year = {2009},
  date = {2009-09},
  volume = {36},
  issue = {2},
  pages = {335--346},
  doi = {http://dx.doi.org/10.1007/s11059-009-0004-6},
  url = {http://www.springerlink.com/index/10.1007/s11059-009-0004-6},
  file = {iovino2009naples.pdf:iovino2009naples.pdf:PDF},
  pdf = {iovino2009naples.pdf}
}

What is happening? What can I do?

[EDIT] Here's a MWE as requested:

\documentclass[12pt, a4paper, twoside, openright, draft]{book}
\usepackage{hyperref}
\usepackage[style=mla,mladraft=true,backend=biber,bibencoding=utf8]{biblatex}
\bibliography{../bibtex/workscited.bib}
\begin{document}
\autocite{iovino2012wilderness}
\printbibliography
\end{document}

Where the iovino2012wilderness entry is:

@INBOOK{iovino2012wilderness,
  author = {Iovino, Serenella},
  title = {The Wilderness of the Human Other: Italo Calvino's 'The Watcher' and a Reflection on the Future of Ecocriticism.},
  booktitle = {The Future of Ecocriticism},
  year = {2012},
  date = {2012},
  editor = {Serpil Oppermann, Ufuk \"{O}zda\breve{g}, Nevin \"{O}zkan and Scott
    Slovic},
  urldate = {2012-12-09},
  file = {iovino2012wilderness.pdf:iovino2012wilderness.pdf:PDF},
  pdf = {iovino2012wilderness.pdf},
  shorttitle = {The Wilderness of the Human Other}
}

This still produces errors:

Missing $ inserted \end
You can't use `\spacefactor' in math mode \end
Missing $ inserted \end
  • 2
    I've just tried your bibtex entry and it does not give me any error. I'm using pdflatex and bibtex. What bibliography style are you using? – Didac Busquets Oct 17 '13 at 9:37
  • 3
    there is something odd about that entry note ^^U^^U^^U.^^P N implies that you have control characters before the title, but the missing $ error is unconnected with the input you show, it occurs on the following page, the under-full bib entry is on page 106 and the error is on the next page, on line 61 of your source file (or one of your source files) – David Carlisle Oct 17 '13 at 10:16
  • Didac: I am using biblatex-mla. – Alessandro Macilenti Oct 17 '13 at 21:58
  • @DavidCarlisle The ^^U^^U^^U.^^P appear on the PDF as emdashes and are used to avoid repeating the author's name. Line 61 in my master document is blank. Line 60 is \appendix, but commenting that throws up the same error. Line 59 is \printbibliography. Commenting l.59 prevents the error from occurring but also does not print my bibliography. :( – Alessandro Macilenti Oct 17 '13 at 22:16
  • Would you be able to narrow down the problem to a nice self-contained MWE? The .bib entry posted above does not seem to be the culprit. Maybe it is the entry just before that in the bibliography (just a guess, might be off by quite some miles). – moewe Oct 17 '13 at 22:18
7

This one was due to the \breve{g}. Eliminating it lets me compile the document. I am using \u{g} instead.

  • 3
    Indeed \breve{g} is a math mode command, while \u{g} produces a breve in text mode. – moewe Oct 18 '13 at 6:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.