8

This question already has an answer here:

I have a quick question about updating my references from Bibtex. I am using TexStudio as my Latex editor.

I have to make changes to some of the references. I put the changes in the "references.bib" file. I then compile the Bibtex and the main document I'm working on. Sometimes the changes show up, and sometimes they don't, and I haven't figured out why. I have even gone as far as trying to delete the references by changing the filename, but the original references still appear. Here's what I put in my main document:

\newpage %Puts in References

\bibliographystyle{unsrt}

\bibliography{references}

My references.bib file shows all the changes I have made. Any suggestions are appreciated!

marked as duplicate by Guido, Werner, Martin Schröder, mafp, cmhughes Oct 24 '13 at 21:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    The normal procedure is: (1) save both your .tex and .bib files(!); (2) latex file.tex, bibtex file.aux, latex file.tex, latex file.tex (note: strictly speaking, the file extensions are detected automatically, but can be included if you like). If this is not getting you what you want, it is time to provide a minimal example (or here). – jon Oct 18 '13 at 2:23
  • Try using an automator like arara – Mr Komandez Oct 18 '13 at 4:40
  • As jon said, in general you have to call latex bibtex latex latex. Do you use the Build command of TeXstudio? This should make all required calls. If not, an example would be helpful. – Tim Hoffmann Oct 18 '13 at 16:33
  • Thanks! I compiled the Latex file twice and deleted the temporary files, and that seemed to do it. – Dave Oct 19 '13 at 16:39
4

Sometimes you need delete all temporary files, like:

.aux, .bbl, .blg, .brf, .dvi, .ilg, .ind, .log, .out, .nav, .snm, .toc, .idx, .lof, .lot, .snm, .bcf, .run.xml, .vrb, ...

And recompile your .tex file:

latex  main.tex
bibtex main.aux
latex  main.tex
latex  main.tex

P.S. Look for some missing comma in .bib file.

  • 2
    Thank you! I think that deleting the aux file and compiling twice did it for me. – Dave Oct 19 '13 at 16:40
2

If that doesn't help, make sure you don't have several .bib files with the same name in your path (and you're updating the wrong one).

0

Maybe this answer shouldn't be in this topic but i don't know were to put it. I lost a lot of time trying to figure out why I couldn't update the references in my .bib files, until I realize that I had to completely disable the UAC (Windows 8). To do this see:

http://www.eightforums.com/system-security/2434-disable-uac-completely.html

Hope it helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.