4

I wish to create key bindings in TeXShop to replace accented characters I commonly use (è, à, é, ç, etc.) with their appropriate LaTeX entries. In the Key Bindings Editor, I add the character as input (e.g., è) and the escaped LaTeX as output (e.g., \`e).

I am using OSX, which allows one to enter è by hitting <option> + ` and then hitting e. When I do this, however, the key binding only replaces the e; the ` persists, which leaves my final output as `\`e. I have tried to use #INS# and #SEL# to produce what I'm looking for, but to no avail. Even the key bindings that come with TeXShop (that are implemented similar to above) provide the same result for me.

One solution that might work is to code a backspace into the output, but I cannot determine how to do that (if it's even possible).

7
  • 1
    Why would you want \`e in the LaTeX file when it's possible to have è?
    – egreg
    Oct 21, 2013 at 7:35
  • @egreg: I apologize; I was unclear in my intent. I want è in my final result, and therefore want it to be replaced by \`e in my LaTeX code (just like many of the Key Bindings that already exist in TeXShop; I'm not sure why the escaped e's were not in there). I hope this clarifies my desire.
    – Geoff Ball
    Oct 21, 2013 at 17:31
  • Is it really necessary to use their LaTeX entries if your are able to enter them the "usual" way? I guess Unicode encoding would be necessary, and I imagine there could be specific reasons not to use UTF.
    – user11208
    Oct 21, 2013 at 17:48
  • @user11208: You're right; it's not vital, as it is quite easy to type \`e. However, if that's the case, why are other key bindings (such as ö being replaced by \"o) pre-programmed into TeXShop?
    – Geoff Ball
    Oct 21, 2013 at 18:03
  • From my point of view, it's partly a remain of the time before Unicode (but I'm perhaps totally wrong). It depends also of the keyboard layout: TeXShop is also designed for people using keyboards that have no direct access to accents.
    – user11208
    Oct 21, 2013 at 19:04

1 Answer 1

3

Be sure that your TeXShop preferences show “Unicode (UTF-8)” in the encoding box

enter image description here

For greater safety, ensure that the line

% !TEX encoding = UTF-8 Unicode

is at the start of your files. You can get the string from the “Macros” menu, choosing the “Encoding” entry and then “Unicode (UTF-8)” in the window that appears.

Then a document such as

% !TEX encoding = UTF-8 Unicode
\documentclass[a4paper]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[italian]{babel} % choose your own language

\begin{document}
à è é ì ò ù
\end{document}

will be typeset with the proper accented letters. No need of doing complicated macros or keyboard substitutions.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .