8

I am dissapointed with microtypes kerning. This MWE:

\documentclass[ngerman,10pt]{article}
\usepackage[ngerman]{babel}
\usepackage{lmodern}
\usepackage[T1]{fontenc}

\usepackage[activate={true,nocompatibility},final,tracking=true,kerning=true,spacing=true,babel]{microtype}

\begin{document}

CUA

\end{document}

… results in:

LaTeX Output

While InDesigns optical kerning results in:

InDesign Output

The subtle difference is the reduced space between the U and the C.

Is there a way to get similar results in LaTeX like in InDesign?

  • I get the log warning Package microtype Warning: No kerning set chosen, no default set declared. Using empty set. with your MWE (and a number of other warnings, too). – cgnieder Oct 21 '13 at 16:53
  • 3
    It's not microtype's kerning you're disappointed with. You're simply using a font with badly spaced capitals, and neither microtype nor TeX are able to do anything about it (obviously, even InDesign's optical kerning isn't either). I suggest you go with a better font or adjust that font's spacing yourself. – Nils L Oct 21 '13 at 19:27
  • 1
    If you are going to use capital letters correctly, you have to kern each letter manually to get a perfect result. Therefore, many typographers warn against using capital letters in for example headings. It is too much work, and requires a trained I to have a good result. Microtype’s letterspacing may improve the result slightly, but will not give a good enough result (neither will InDesign). – Sveinung May 7 '14 at 7:37
14

Microtype's kerning option is intended to set additional kerning around individual characters. You have to specify those characters and kerning amounts with a \SetExtraKerning command. It is not done automatically and there is no optical kerning (except in your own eyes when you make such a setting). The configuration file microtype.cfg does this for a few characters. For example, in french contexts, some punctuation has extra space added before it. But no change in kerning for either C or U is used. Since the extra kerning feature applies to an individual character, whatever its context, you normally would not use it except in very special cases.

So what you get in your MWE is the kerning set by the font. You have to either change fonts or do something to explicitly change the kern. In fonts intended for titles, spacing between uppercase letters can be an issue, but many fonts do not seem to care.

| improve this answer | |
  • 2
    one might add that it's not just microtype that doesn't offer optical kerning -- it's structural limitations in TeX's typesetting that prevent it. To TeX, each glyph is contained inside a (I guess: black) box. TeX knows the outer dimensions of those boxes, but has no clue (and doesn't care) about what the glyph looks like that's inside it. – Nils L Oct 21 '13 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.