2

My bibliography shows bookmarks to the footnotes like "5, 27, 28" which link to where I cited the book. However I also cite some books in my glossary which resides on roman numbered pages before the main part (which starts with page 1 again). For those cases the links in my bibliography read "(document)" and link to the front page (not the glossary).

Solution: I misunderstood the naming scheme. In fact "document" means that the reference is contained in the main text. It will only give numbers to footnote. This behaviour can be changed with backref und pagebackref options so that instead of "document" it will give the page number or whatever.

For further tweaks one might use \renewcommand*\backref[1]{\ifx#1\relax \else (page #1) \fi} to add the word "page" before each backlink. It's confusing but there you go.

  • Bump in the hope someone might be able to help who hasn't seen this. Thanks! – user38088 Oct 25 '13 at 7:51
2

The linking via page numbers will not work properly, if hypertexnames is disabled. Therefore it should not set to false. The following example works for me:

\documentclass{article}
\usepackage[
  pagebackref,
  hypertexnames, % default is true since a long time
  colorlinks,
]{hyperref}
\renewcommand*{\backref}[1]{%
  \ifx\relax#1\empty
  \else
    (page #1) %
  \fi
}
\begin{document}
  \pagenumbering{roman}
  First page \cite{abc}.
  \newpage
  Second page \cite{abc}.
  \newpage
  \pagenumbering{arabic}
  Third page \cite{abc}.
  \newpage
  Fourth page \cite{abc}.
  \newpage
  \begin{thebibliography}{9}
    \bibitem{abc} Foo bar.

  \end{thebibliography}
\end{document}

Result

And the destination names are page.i, page.ii, page.1, page.2 as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.