2

so I've been trying for a while to configure those two programs, but I just can't get it to work. I always get the error: [ForwardSearch("%bm.pdf","%Wc",%l,0,0,... Cannot execute the command.

My settings are: The following are my settings.

  • Please add the full command you are using (the executable path) – papabravo Oct 23 '13 at 19:05
  • Welcome to TeX.SX! Usually, we don't put a greeting or a “thank you” in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Accepting and upvoting answers is the preferred way here to say “thank you” to users who helped you. – Mario S. E. Oct 23 '13 at 19:06
  • 2
    Have you looked at this? tex.stackexchange.com/questions/116981/… – Mario S. E. Oct 23 '13 at 19:07
  • @papabravo this is the executable path: "C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe" -inverse-search "\"C:\Programme (x86)\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto('%f','%l')]\"" – emmak Oct 23 '13 at 19:32
  • @MarioS.E. yes that's what I used, I have no idea where I went wrong.. – emmak Oct 23 '13 at 19:33
3

This configuration works for me.

Executable path

C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Program Files\TeXnicCenter\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto('%f','%l')]\""

View project's output

DDE command

Command:"%bm.pdf"

Server: SUMATRA

Topic: control

Forward Search

DDE command

Command:[ForwardSearch("%bm.pdf","%Wc",%l,0,0,1)]

Server: SUMATRA

Topic: control

Close document before running (La)TeX

Do not close

enter image description here

  • It does not work for me. After TeXnicCenter opens Sumatra, if I double click on a word, Sumatra displays the error "Cannot start inverse search command. Please check the command line in the settings". – Antonio Sesto Jul 15 '16 at 8:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.