0

I want to use the 'et al' form for the second and third of three authors in a citation in a paragraph. I've the following test entry in Jabref

@ARTICLE{testKey,
author = {Della Mirandola, A and Della Mirandola, B and Della Mirandola,
C},
title = {Title of Paper},
 journal = {Working Paper, Institute},
 year = {2013},
 owner = {User},
timestamp = {2013.08.05}
}

I'm sure sure if this approach is using bibtex, biblatex or natbib or whatever, but I have to use a .bst file to format my bibliography (http://pages.stern.nyu.edu/~dbackus/GE_asset_pricing/BGTZ/jf.bst) as I need to follow a specified format, so I want to continue creating the .bbl file automatically in TexnicCenter like this:

\bibliographystyle{elsart-harv}
\bibliography{C:/jabrefBib}

and just citing the references in the document as usual (\cite{Key}).

I understand that the .bst file states that it shows the full list of authors the first time the paper is cited, but I can't get it to give the authors as Della Mirandola et al. (2013) rather than Della Mirandola, Della Mirandola, and Della Mirandola (2013)

How can I do this? Am I confined to the code in the .bst file?

1

Try using the natbib option longnamesfirst.

makes the first citation of any reference the equivalent of the starred variant (full author list) and subsequent citations normal (abbreviated list);

Also you could have a look at natbib reference sheet for more options using natbib.

you could also try to use the shortcites command from natbib

\shortcites{key-list}
  • That entry is in the .cls file (\documentclass[oneside,12pt]{CUEDthesisPSnPDF} from www-h.eng.cam.ac.uk/help/tpl/textprocessing/ThesisStyle) for this document as follows: \usepackage[round, sort, authoryear, longnamesfirst]{natbib} so there must be something overriding it. Could it be something in the .bst file? – user2146441 Oct 24 '13 at 10:18
  • I can't see it in the .bst, but the nature of the longnamesfirst is that it will give all authors the first time you use the reference, and in all subsequent citings it will use et.~al. Removing the longnamesfirst in the .cls should give you et.ãl for all references longer than x authors. – rakke Oct 24 '13 at 10:22
  • I tried that: there's something up. Even if I change the entry in the .cls file to just \usepackage{natbib} it still lists out all the authors. I can't find any natbib entries in the .bst file at pages.stern.nyu.edu/~dbackus/GE_asset_pricing/BGTZ/jf.bst or anywhere else in the document. What could be over-riding this format, do you think? – user2146441 Oct 24 '13 at 10:26
  • try my edit to the initial answer; shortcite. Does this help? – rakke Oct 24 '13 at 10:27
  • No. Also none of the other variations of \cite (\citet, \citet* etc) are working only \cite and \citep are changing what's displayed. The .bst file states the following: There are style changes that may be specified in the text with the command \citationstyle. \citeasnoun{key} ==>> Jones et al. (1990) \cite{key} ==>> (Jones et al. 1990) \cite[chap. 2]{key} ==>> (Jones et al. 1990, chap. 2) On the first citation of any work, the full author list is used. Any ideas? – user2146441 Oct 24 '13 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.