3

@egreg's answer to How to add \printindex to tableofcontents provides multiple options to add the index to the table of contents, but you can see from the screenshot below that the headers in memoir still reflect an older chapter. Is there any way I can add a new chapter to reflect the index name (in this case General Index) in the header without having a new page started?

\documentclass{memoir}
\let\bf=\bfseries
\usepackage{multind}

\makeindex{idx}

\begin{document}
\chapter{Some Chapter}

Some \index{idx}{text}text, and \index{idx}{some}some more \index{idx}{text}text.

\appendix

\printindex{idx}{General Index}
\end{document}

problem output

In essence, I'd like something such as this:

Chapter 1
Some Chapter

Some text, and some more text.

...
...
...

----------------------------------------------------------------

                                         CHAPTER 1: SOME CHAPTER

blah blah blah

...
...
...

----------------------------------------------------------------

Appendix A
General Index

some, 1
text, 1

...
...
...

----------------------------------------------------------------

                                       APPENDIX A: GENERAL INDEX

blah, 2

...
...
...
3

The following lines in multind.sty (version 1.1a, 29 August 1991) tell you what happens:

\def\printindex#1#2{\@restonecoltrue\if@twocolumn\@restonecolfalse\fi
  \columnseprule \z@ \columnsep 35pt
  \newpage \twocolumn[{\Large\bf #2 \vskip4ex}]
  \markright{\uppercase{#2}}
  \addcontentsline{toc}{section}{#2}
  \@input{#1.ind}}

% The following index commands are taken from book.sty.
% \theindex is modified to not start a chapter.

\def\theindex{\parindent\z@
 \parskip\z@ plus .3pt\relax\let\item\@idxitem}

Using a pre-LaTeX2e package, unmodified in 22 years, doesn't seem the best course of action.

For a single index just don't load multind; for multiple indices you can choose between index and imakeidx, both compatible with memoir (which one I'd prefer is clear).


Don't say \let\bf=\bfseries. Why should you? There's no advantage in using a command that, in other classes, is defined with a different semantics.

  • As for \let, it was a hotfix for the \printindex, which uses \bf, not defined in memoir without option oldfontcommands. I'll give imakeidx a spin :). – Sean Allred Oct 24 '13 at 23:56
  • Memoir does not use \bf, it comes from the outdated package you are using. As egreg says, don't use outdated packages. – daleif Oct 26 '13 at 10:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.