15

For some reason, BibLaTeX doesn't work. Here's my minimal example.

\documentclass[a4paper]{article}

\usepackage[utf8]{inputenc}
\usepackage{csquotes}

\RequirePackage{filecontents}
\begin{filecontents}{refs.bib}
@book{doe13,
    address    = {City},
    title      = {A nice title},
    shorttitle = {Short title},
    publisher  = {Publisher},
    author     = {Doe, John},
    year       = {2013}
}
\end{filecontents}

\usepackage[backend=biber]{biblatex}
\addbibresource{refs.bib}

\begin{document}

Hello. \cite{doe13}.

\nocite{*}

\printbibliography

\end{document}

I am using MiKTeX 2.9 32-bit.

When I run pdflatex sample.tex, I get the following warings:

LaTeX Warning: Citation 'doe13' on page 1 undefined on input line 23.
LaTeX Warning: Empty bibliography on input line 27.

The generated PDF contains

Hello. [doe13 ].

and the page number, nothing else. There's no bibliography.

Running biber sample gives me the following message:

> biber sample
INFO - This is Biber 1.5
INFO - Logfile is 'sample.blg'
data source C:\Users\Paul\AppData\Local\Temp\par-5061756c\cache-890efc00b3ca6b77
5c7d44a325c1349fb2a3a3bd\inc\lib/Biber/LaTeX/recode_data.xml not found in .

Like Alan Munn stated, the warning in biber can be fixed by removing the entire directory C:\Users\Paul\AppData\Local\Temp\par-5061756c. After that, new warnings occur, the pdflatex warnings are the same as well as the resulting PDF.

> biber sample
INFO - This is Biber 1.5
INFO - Logfile is 'sample.blg'
INFO - Reading 'sample.bcf'
WARN - Warning: Found biblatex control file version 2.5, expected version 2.3
INFO - Using all citekeys in bib section 0
INFO - Processing section 0
INFO - Looking for bibtex format file 'refs.bib' for section 0
INFO - Decoding LaTeX character macros into UTF-8
INFO - Found BibTeX data source 'refs.bib'

What else can I do?

  • 4
    Probably this is the problem: Question mark instead of citation number. You need to run pdflatex, biber, and then pdflatex twice more. – Alan Munn Oct 26 '13 at 2:31
  • 1
    I don't get a question mark, so this question doesn't help me. I get [doe13 ] instead. I updated the question for clarification. – pvorb Oct 26 '13 at 14:27
  • 1
    Did you run pdflatex, biber, pdflatex and pdflatex though? How do you compile your documents? – moewe Oct 26 '13 at 14:58
  • I suspect you're only running pdflatex. You need to follow the full run sequence suggested by moewe. Another potential explanation for your problem is that you may be mistakenly running bibtex instead of biber. Tell us which LaTeX editor/IDE you're using and which OS you're using. biber may not be already set up in it, in which case people here can tell you how to do that. – jub0bs Oct 26 '13 at 15:06
  • 2
    The fact that you get the citation key instead of a question mark is just the difference between biblatex and natbib. The error you are getting is a well known issue with biber that is easily fixed. See XeLaTeX and Biber do not Produce a *.bbl File for a solution. – Alan Munn Oct 26 '13 at 15:34
4

According to the biber log it seems that biber and biblatex are out of sync. An upgrade to the most recent version of biber should fix the issue.

13

The error you are getting is a well known issue with biber. It creates binaries in a cache folder, and sometimes that can get corrupted. In order to solve the problem, you need to manually delete the cache folders. They are located in different places on different platforms:

  • /var/folders/*/*/*/ (OSX, local GUI login shell)
  • /var/tmp/ (OSX (remote ssh login shell), Unix)
  • /tmp/ (Linux)
  • C:\Documents and Settings\<username>\Local Settings\Temp (Windows/Cyg- win)
  • C:\Windows\Temp (Windows)
  • C:\Users\<username>\AppData\Local\Temp (Windows)

So in your case you can delete the folders inside C:\Users\Paul\AppData\Local\Temp, and then recompile your document with pdflatex, biber, pdflatex, pdflatex.

  • Unfortunately this doesn't resolve my problem. Sorry. It changed the warnings in biber but didn't change the warnings in pdflatex. I updated the question with the new warnings. – pvorb Oct 27 '13 at 2:34
  • 1
    Nevertheless +1 for the precise answer. :) – pvorb Oct 27 '13 at 2:43
  • 1
    One can find out the cache folder using biber --cache. This can also be passed to rm: rm -rf `biber --cache`. – fiedl May 16 '17 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.