2

I'm using the following in my main.tex file:

\documentclass[12pt,oneside]{article}
\usepackage[utf8]{inputenc}
\usepackage[danish]{babel}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{graphicx}
\graphicspath{ {images/} }
\usepackage{caption}
\usepackage{subcaption}
\usepackage[a4paper,width=140mm,top=25mm,bottom=25mm]{geometry}
\usepackage{url}


\usepackage[style=authoryear,sorting=none,backend=biber,maxbibnames=10]{biblatex}
\DefineBibliographyStrings{danish}{andothers = {et\addabbrvspace al\adddot}}
\addbibresource{references.bib}
\setlength\bibitemsep{1.5\itemsep}
\renewcommand*{\nameyeardelim}{\addcomma\space}

In my references.bib file I have:

@article{edwards,
    author        = {N. Edwards, P.},
    title         = {History of climate modeling},
    journaltitle  = {WIREs Clim Change},
    year          = {2011},
    volume        = {2},
    pages         = {128--139},
    doi           = {10.1002/wcc.95}
}

@article{flato,
    author        = {M. Flato, G.},
    title         = {Earth system models: an overview},
    journaltitle  = {WIREs Clim Change},
    year          = {2011},
    volume        = {2},
    pages         = {783--800},
    doi           = {10.1002/wcc.148}
}

@incollection{heymann,
    author    = {Heymann, M. and Sandøe, P. and Andersen, H.},
    title     = {What is climate science all about? Philosophical perspectives},
    booktitle = {Jorden Brænder},
    editor    = {Gjerris, M. and Gamborg, C. and Olesen, J.E. and Wolf, J.},
    publisher = {Forlaget Alfa},
    address   = {Frederiksberg},
    year      = {2009},
    pages     = {65--67}
}

@incollection{heymann2,
    author    = {Heymann, M.},
    title     = {Climate science – how did it come about?},
    booktitle = {Jorden Brænder},
    editor    = {Gjerris, M. and Gamborg, C. and Olesen, J.E. and Wolf, J.},
    publisher = {Forlaget Alfa},
    address   = {Frederiksberg},
    year      = {2009},
    pages     = {69--87}
}

@incollection{IPCC,
    author    = {Le Treut, H. and Somerville, R. and Cubasch, U. and Ding, Y. and Mauritzen, C. and Mokssit, A. and Peterson, T. and Prather, M.},
    title     = {Historical Overview of Climate Change},
    booktitle = {Climate Change 2007: The Physical Science Basis. Contribution of Working Group I to the Fourth Assessment Report
    of the Intergovernmental Panel on Climate Change},
    editor    = {Solomon, S. and Qin, D. and Manning, M. and Chen, Z. and Marquis, M. and Averyt, K.B. and Tignor, M. and Miller, H.L.},
    publisher = {Cambridge University Press},
    address   = {Cambridge, United Kingdom and New York, NY, USA},
    year      = {2007},
    pages     = {95--122}
}

And at the bottom of my main.tex file I have:

\nocite{*}

\renewcommand{\mkbibnamefirst}[1]{\textsc{#1}}
\renewcommand{\mkbibnamelast}[1]{\textsc{#1}}
\renewcommand{\mkbibnameprefix}[1]{\textsc{#1}}
\renewcommand{\mkbibnameaffix}[1]{\textsc{#1}}

\printbibliography

\end{document}

When I Build & View my main.tex I get no errors, but still, the bibliography isn't being printed. I do get some warning at the line where \printbibliography is, that says:

Empty bibliography

There were undefined references.

Please (re)run Biber on the file:(biblatex) main(biblatex) and rerun LaTeX afterwards.

I'm am using the latest version of TeXstudio, and up until recently, I have actually been able to get the bibliography printed.

I'm not entirely sure how to "(re)run Biber..." as it says in the warning, but I have cleaned all aux files, tried to restart TeXstudio and so forth.

So what am I doing wrong here ?

Thanks in advance.

  • 2
    Build and View is the compiler, or whatever it is called, in TeXstudio. The commandline I use for that is: txs:///pdflatex | txs:///biber | txs:///pdflatex | txs:///pdflatex | txs:///view-pdf – Denver Dang Oct 27 '13 at 18:52
  • I don't think it is TeXstudio. I have tried to run it in ShareLatex, and there I get the same. The document is compiled, but the bibliography is not shown. – Denver Dang Oct 27 '13 at 19:27
  • That should be the case. It does run biber, and if I'm not mistaken, sharelatex should take care of that compared to editors. And even there it does not work :/ – Denver Dang Oct 27 '13 at 19:41
  • Okay. This might be a stupid question, but how do I do what you say ? I'm pretty new to LaTeX, so I have no idea how to "command line" stuff and such :/ – Denver Dang Oct 27 '13 at 19:57
  • 1
    What exactly happens if you run biber main, do you get any output: warnings errors etc.? Or you you still get ` 'biber' is not recognized as an internal or external command, operable program or batch file. In that case try to add the directory biber` is in to the PATH so Windows can find it (or start biber explicitly). – moewe Oct 30 '13 at 7:54