3

At the beginning, my purpose is to set up AUCTeX with Emacs. I just do like below

  1. Download AUCTeX, then cd to the directory, make and sudo make install.
  2. It works well when the .tex file only contains english characters. But when I create a .tex with Japanese characters and enter command C-c C-c. It will prompt error message

LaTeX Error: This file needs format 'pLaTeX2e' but this is 'LaTeX2e'

I search on google and find It is because LaTex2e don't support Japanese characters. I should install pLaTeX2e as well. At last I found command

$ sudo port install texlive +full

on the site http://oku.edu.mie-u.ac.jp/~okumura/texwiki/?Mac#f8cc2ba3. It is really a horrible command; it uses almost 7GB storage but the issue is still not resolved.

Anyone who has any suggestion to delete this file completely or resolve this error issue?

5
  • 2
    First I don't think it has anything to do with AUCTeX nor with emacs. Secondly, did you try sudo port uninstall texlive?
    – Dror
    Commented Oct 28, 2013 at 15:40
  • still not, I'm afraid This command will not remove file completely, so I think it will be better to ask first.
    – ryu
    Commented Oct 28, 2013 at 15:42
  • 1
    In terms of removing this installation, I think this is the way to go. Maybe you would like to run sudo port uninstall --follow-dependencies. See port help uninstall for help.
    – Dror
    Commented Oct 28, 2013 at 15:56
  • 1
    I think Macports is pretty good about placing everything inside /opt, so (worst case scenario) you could start again from scratch if all else fails. There is also a MacTeX.pkg that is 2.3GB that you could download and install without using Macports: tug.org/mactex
    – lawlist
    Commented Oct 28, 2013 at 18:27
  • 2
    Continuing from what @lawlist suggested, MacTeX is probably the easiest option here, along with GNU Emacs compiled for OSX. You can install AUCTeX from within Emacs via M-x list-packages. Commented Nov 2, 2013 at 22:26

1 Answer 1

4

Here's an answer based on the comments.

As others have noted, this problem isn't really about Emacs or AucTeX, but about your TeX Distribution. And here, the problem is MacPorts. The de facto standard Mac distribution is the MacTeX distribution. You should generally avoid other types of package manager versions of TeX Live. See Adding a CTAN package to a MacPorts-maintained TeX installation for some discussion of why.

To remove a MacPorts port, you need to use

sudo port uninstall --follow-dependents <portname>

So use this to uninstall the TeX port you added.

Then do a fresh install of MacTeX.

This will set your TeX binary directory to /usr/texbin.

For a MacOS version of emacs see: this link, or use Aquamacs.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .