2

I am using the tufte-book class, and the \footnote and \sidenote commands do not seem to be working properly, while marginnotes work.

When I use either \footnote{} or \sidenote{} (no number, but this is, according to the manual, not required), I get two errors: missing number, treated as zero and illegal unit of meassure (pt inserted).

Code example:

\documentclass[justified]{tufte-book}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern} % lettertype met alle karakters
\usepackage[dutch]{babel}
\usepackage{natbib}
\usepackage{eurosym}
\usepackage[stable]{footmisc}
\title{Footnotes and sidenotes}
\author{Ben}
\date{} 
\begin{document}


\maketitle

\section*{Footnotes and sidenotes}
Main text \footnote{Footnote text}

More main text \sidenote{Sidenote text}
\end{document}

How do I resolve this issue?

  • 2
    Welcome to TeX.SX! Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – lockstep Oct 29 '13 at 16:36
  • @Ben, I've used it extensively but I don't think that your problem relates to the class specifically. One usually gets that on specifying a unit in an option without specifying the unit. dickimaw-books.com/latex/novices/html/length.html#tab:units shows the accepted units. Another problem might also be that you have an incorrectly defined table. As lockstep mentioned, a MWE will be infinitely helpful to identify your specific problem. – Forkrul Assail Oct 29 '13 at 17:04
3

I found out what was wrong through experimentation.

My original code looked like this:

\documentclass[justified]{tufte-book}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern} % lettertype met alle karakters
\usepackage[dutch]{babel}
\usepackage{natbib}
\usepackage{eurosym}
\usepackage[stable]{footmisc}
\title{Footnotes and sidenotes}
\author{Ben}
\date{} 
\begin{document}


\maketitle

\section*{Footnotes and sidenotes}
Main text \footnote{Footnote text}

More main text \sidenote{Sidenote text}
\end{document}

When I was asked by @lockstep to provide an example, I removed what I thought to be irrelevant packages, but then it suddenly worked. It was soon clear that the package footmisc seems to be incomatible with tufte-book. Removing this package (and resorting to the manual option of \section[Sectiontitle without footnotes]{Sectiontitle \footnote{Footnote}} works.

  • 2
    The footmisc package redefines the \footnote command, overwriting the Tufte-LaTeX definition of \footnote. So, as you discovered, the footmisc package and Tufte-LaTeX document classes are incompatible. – godbyk Oct 29 '13 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.