I recently upgraded to OS X 10.9 Mavericks and installed BasicTex 2013 (TeXLive-2013-Basic), in addition to TeXLive-2013. Now I need to use the TexLive-2013 as my default distribution, but the Tex Distribution Pane in System Preferences doesn't work anymore. It asks for my admin password, but doesn't actually changes the distribution.

Has anybody run into the same problem? Is it Mavericks or BasicTex that has broken the TeX Distribution Pane? If so, is there a way to repair it so that it can change the distribution?


  • 1
    Why don't you install MacTeX and forget about all problems?
    – egreg
    Oct 30, 2013 at 16:59
  • 1
    I can confirm the issue trying to switch between TL2013 and TL2012. I've contacted Dick Koch who manages the MacTeX distribution and he's looking into it.
    – Alan Munn
    Oct 30, 2013 at 17:04
  • Why would you install TL 2013 Basic in addition to TL 2013? Basic is just a proper subset of the full version as far as I know so you are simply duplicating a fraction of the stuff you already had installed.
    – cfr
    Apr 26, 2014 at 0:57

2 Answers 2


The TeX Distribution panel provides a simple GUI interface to what is essentially changing a symbolic link. You can change this link manually, by doing the following in the Terminal. (Information provided by Dick Koch. This is a temporary fix until the preference pane is updated.)

cd /Library/TeX/Distributions/.DefaultTeX

This folder will contain just one item, a symbolic link named Contents.

To change, for instance, to TeXLive-2013,

sudo rm Contents

sudo ln -s ../TeXLive-2013.texdist/Contents Contents

To change to other distributions, look up their names in

  • Actually, this comment solves LaTeX distribution switching, but it does not answer the original question, i.e., how to solve error thrown at clicking on Tex Distribution pane in Mac Preferences.
    – Israel
    Jul 27, 2019 at 8:29
  • There is a thread in a Nabble.com forum, which explains that pane function has been removed since 2016 distribution, so you may remove Tex distribution icon in MacOs Preferences.
    – Israel
    Jul 27, 2019 at 8:35
  • 1
    @Israel If you notice, the answer is dated 2013/10/30, so it couldn't deal with things happened three years later. The answer was correct at the time it was written, when the preferences pane existed and was generally functional; the issue was about switching to BasicTeX 2013, which didn't work because of a bug in the BasicTeX distribution. The answer is still correct for people having the same problem.
    – egreg
    Jul 27, 2019 at 16:09
  • The answer is still correct today.
    – my2cts
    Apr 11, 2020 at 19:11

I'd like to summarize some of what I've experienced in case others come along having a similar problem. Since the underlying problem is likely not with BasicTeX, and others' answers aren't related to it either, I'm going to be more general....

My Problem:

I also have this problem, but with TeXLive and/or MacTex (I think...). I have TeXLive 2012 and couldn't update it via the Tex Live Utility app because the TLU said that I needed to do a full upgrade to TexLive-2103, as shown: Screenshot of Tex Live Utility's message

What I Tried:

I downloaded TexLive 2013 and installed it. Although it successfully installed (a la latex --version ==> 2013), the TeX Distribution preference pane indicated I only had TeXLive-2012:

Screenshot of TeX Distribution preference pane

Evidently, I have the following distributions (I thought I had just TeXLive-2012):

ls /Library/TeX/Distributions

   Fink-teTeX.texdist/          MacPorts-teTeX.texdist/    TeXLive-2012.texdist/
   MacPorts-TeXLive.texdist/    TeXDist-description.rtf

Following the "related question" linked below, I checked to see where all related directories were:

ls -l /Library/TeX

drwxr-xr-x  9 root  wheel  306 Jul 10  2012 Distributions/
lrwxr-xr-x  1 root  wheel   38 Jul 10  2012 Documentation -> Distributions/.DefaultTeX/Contents/Doc
lrwxr-xr-x  1 root  wheel   45 Jul 10  2012 Local -> Distributions/.DefaultTeX/Contents/TexmfLocal
lrwxr-xr-x  1 root  wheel   39 Jul 10  2012 Root -> Distributions/.DefaultTeX/Contents/Root

I could definitely fix this by changing some soft links -- specifically, if I changed Distributions/.DefaultTex to point to a different distribution -- but I think part of the issue is that I was installing TeXLive-2013 when I should have been installing the larger package, MacTeX 2013, which contains TeXLive-2013, plus an updated TeX Live Utilty, among other things. Other posters seem to be confused by this as well.

Related Question: How can I tell TeX Live Utility where my TeX distribution is?

I admit that this is not a solution, but I hope it adds to the discussion and that somebody finds it helpful!

  • Downloading/installing the latest version of MacTeX (as opposed to TeXLive) worked for me!
    – jvriesem
    May 1, 2014 at 18:22
  • MacTeX will install the .texdist directories for distributions you don't have (e.g., Fink-teTeX), but they're just stubs. Sep 4, 2014 at 1:36
  • For the record, you're not the only person who had this problem. Short of recompiling the preference pane (!) or your downloading MacTeX solution, I couldn't figure this out. Unfortunately, MacTeX is even bigger than TeX Live, I guess.
    – kcrisman
    Dec 5, 2014 at 21:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .