6

My LaTeX document is English but when I cite multiple authors

Teyseyre und Campo

occurs instead of

Teyseyre and Campo

I set \selectlanguage{english} and for every single entry I added language = {english}.

I also tried adding the following which I found in another thread:

\usepackage{babelbib} 
\selectbiblanguage{english}

\renewcommand\betweenauthors{and}
\providecommand\harvardand{}
\renewcommand\harvardand{and}

Tt still displays the German "und". Can someone help me getting rid of it?

11
  • Do you use BibLaTeX? If you do, \usepackage[english]{babel} fixes your issue.
    – ppr
    Oct 30 '13 at 18:51
  • 3
    natbib is not a 'style': what argument are you giving \bibliographystyle?
    – jon
    Oct 30 '13 at 19:16
  • 1
    You should consider change from natbib to biblatex. Biblatex has a better language support and is more flexible. To achieve what you want with biblatex you need only the babel line, the .bib call \bibliography{file.bib} and \usepackage[style=authoryear-comp]{biblatex} (or whatever style you want.
    – ppr
    Oct 30 '13 at 19:19
  • 2
    @jon I use natdin then
    – keinabel
    Oct 30 '13 at 19:21
  • 1
    @keinabel Switching to biblatex is (unfortunately) not as simple as changing one line in the preamble. You might want to read What to do to switch to biblatex, biblatex for idiots and bibtex vs. biber and biblatex vs. natbib. natdin.bst is a German citation style and thus uses German localisation, some words can be changed though. Is it only the "and" you are interested in, or is there more?
    – moewe
    Oct 30 '13 at 19:35
8

The bibliography style natdin lets users cite and reference pieces according to the German standard "DIN 1505, Parts 2 and 3" (citing from the header of natdin.bst). As such, it shouldn't come as a surprise that you get the German connector particle "und" rather than, say, "and". Changing parameters such as \harvardand will have no effect whatsoever since the natdin bibliography style doesn't use that macro.

Assuming you want to stick with natdin as your bibliography style and all you want to do is change the connector particle from "und" to "and", you could proceed as follows:

  • Find the file natdin.bst on your computer and make a copy, to be called, say, mynatdin.bst. (Never edit an original file that's part of the TeX distribution directly.)

  • Open mynatdin.bst in your favorite text editor and search for the BibTeX function named und. (It's on line 181 in my copy of this file.) Given your description, this function is probably set up as

    FUNCTION { und } { " und " }
    

    Change it to

    FUNCTION { und } { " and " }
    
  • Next, search for the function ua.etal (probably just a few lines up from the und function). Change it so that it says

    FUNCTION { ua.etal } { " et~al." }
    
  • Save the file mynatdin.bst, either in the directory where your main tex file is located or in a directory that's searched by your TeX distribution. If you choose the latter option, you will probably also need to update/refresh the TeX filename database in an appropriate way.

  • Start using the new bibliography style my issuing the command

    \bibliographystyle{mynatdin}
    

    in your main tex file. Be sure run LaTeX, BibTeX, and LaTeX twice more to fully update the work of BibTeX and LaTeX.

0

Example: I want a quote in English, but it is appearing in Portuguese, as follows:

According to Enevoldsen and Xydis (2015) xxxxxxxx (the letter "e" appears in Portuguese) According to Enevoldsen and Xydis (2015) xxxxxxxx (I want it)

########## Solution #############

Look for features with the extension ".bst", if you have more than one feature of this, you will have to change all of them. Now in this feature search for the function "FUNCTION {bbl.and}", then search for the letter of your language (in this case "e") and change to the desired language (in this case "and"). Don't forget to change all ".bst".

1
  • Welcome to TeX.SE. Modifying the existing bst file is essentially the existing answer. It does have the better advise to copy the file so that you're only editing a local version, and not the original file.
    – Teepeemm
    Oct 8 '20 at 0:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.