4

I've got a document using the scrartcl and fontspec packages, like so:

\documentclass[a4paper]{scrartcl}
\usepackage{fontspec}

I'm setting the fonts using the following:

\setmainfont[Ligatures={Common,TeX}]{Minion Pro}
\setsansfont{Myriad Pro}
\setmonofont[Scale=0.8]{Consolas}

Then creating a title:

\title{Document Title}
\author{Author Name}
\date{}
\maketitle

This works great, however while the title is set in my sans serif font, the author appears in the main font. What do I need to do to get the author to appear in the sans serif font as well?

3

As soon as the current KOMA-Script version (3.11b) is updated, the following addition to your preamble should suffice:

\setkomafont{author}{\sffamily}

With version 3.11b, one may use the xpatch package to add \sffamily to the code responsible for typesetting the author names.

\documentclass[a4paper]{scrartcl}

\usepackage{fontspec}
\setmainfont[Ligatures={Common,TeX}]{Minion Pro}
\setsansfont{Myriad Pro}
\setmonofont[Scale=0.8]{Consolas}

\usepackage{xpatch}

\makeatletter
\xpatchcmd{\maketitle}{% with the `titlepage` class option
  \@author
}{%
  \sffamily\@author
}{}{}
\xpatchcmd{\@maketitle}{% without the `titlepage` class optipn
  \@author
}{%
  \sffamily\@author
}{}{}
\makeatother

\begin{document}

\title{Document Title}
\author{Author Name}
\date{}
\maketitle

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.