16

I'm getting odd behavior using package tocloft to format my table of contents and center the titles "Contents", "List of Figures", and "List of Tables". Using the code suggested in the tocloft documentation, I tried to center "Contents" with:

\renewcommand{\cfttoctitlefont}{\hfill\Large}
\renewcommand{\cftaftertoctitle}{\hfill}

but instead of centering, this right justifies the title, even though the exact same code works to center the list of figures and list of tables titles.

In my minimal working example, I can get this working by replacing the first \hfill with \hfil, but in my actual document that fix causes the title to be somewhere in between left and center. I am trying to understand why \cfttoctitlefont is not working the same as \cftlottitlefont and \cftloftitlefont, so that I can address the problem in my actual document.

Minimal working example:

\documentclass{article}
\usepackage{tocloft}
\renewcommand{\cfttoctitlefont}{\hfill\Large}
\renewcommand{\cftaftertoctitle}{\hfill}
\renewcommand{\cftlottitlefont}{\hfill\Large}
\renewcommand{\cftafterlottitle}{\hfill}

\begin{document}
\tableofcontents
\listoftables
\section{Section}
\begin{table}[h]
\centering
\begin{tabular}{ l | c || r }
\hline
1 & 2 & 3 \\ 
\hline
\end{tabular}
\caption[Example table]{This is a table.} 
\end{table}
\end{document}

Thank you!!

14

There's indeed something in the example code of the tocloft package that's not quite correct about how to get the string "Contents" centered on a line. Anyway, you can achieve your objective by issuing the commands

\renewcommand{\contentsname}{\hfill\bfseries\Large Contents\hfill}   
\renewcommand{\cftaftertoctitle}{\hfill}

Note the \hfill inserted after "Contents". If you would rather have the string "Contents" be set in normal size and normal weight, you'd use \normalfont\normalsize instead of \bfseries\Large.

A full MWE, applying these changes to the header of the List of Tables as well:

enter image description here

\documentclass{article}
\usepackage{tocloft}
\renewcommand{\contentsname}{\hfill\bfseries\Large Contents\hfill}   
\renewcommand{\cftaftertoctitle}{\hfill}
\renewcommand{\listtablename}{\hfill\bfseries\Large List of Tables} % no \hfill after "List of Tables"...
%%% using the command "\renewcommand{\cftlottitlefont}{\hfill\bfseries\Large}" works too...
\renewcommand{\cftafterlottitle}{\hfill}

\begin{document}
\tableofcontents
\listoftables
\section{Section}
\begin{table}[h]
\centering
\begin{tabular}{| l | c | r |}
\hline
1 & 2 & 3 \\ 
\hline
\end{tabular}
\caption[Example table]{This is a table.} 
\end{table}
\end{document}
  • Perfect! Worked for my actual document as well. – Katie R Nov 6 '13 at 17:24
  • The 10th upvote on this answer, on 2018-08-16, earned me badges 1,110 and 1,111 [!] on this site. Many thanks!!! – Mico Aug 16 '18 at 21:57
6

Actually your solution is almost correct. The reason why it is not working is the fact that LaTeX removes the horizontal space that comes at the end of a line. This answer further elaborates on this fact but to prevent this either you need to insert a dummy text -- e.g., \null{}, \mbox{}, \hfill -- after the last \hfill:

\renewcommand{\cfttoctitlefont}{\hfill\Large}
\renewcommand{\cftaftertoctitle}{\hfill\hfill} %Note the second \hfill, it could have been any dummy text

and Mico's solution effectively does that by ending \contentsname with an \hfill and simultaneously setting \cftaftertoctitle to \hfill.

Or, you could use \hspace*{\fill} so that your code becomes:

\renewcommand{\cfttoctitlefont}{\hspace*{\fill}\Large}
\renewcommand{\cftaftertoctitle}{\hspace*{\fill}}

and Mico's solution becomes:

\renewcommand{\contentsname}{\hspace*{\fill}\bfseries\Large Contents\hspace*{\fill}}   
%\renewcommand{\cftaftertoctitle}{\hspace*{\fill}} % Alternatively, you can delete the last \hspace*{\fill} from the above line and uncomment this line.

This last \contentsname definition works with both tocloft package and the original LaTeX toc command as well.

1

Simply using the following works too:

 \renewcommand{\contentsname}{\centering Contents}
  • This only works if you're not using tocloft. – Werner May 6 '16 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.