3

When I do BibTeX references using the alpha style, they are slightly shifted to the left from the rest of the text. How can I align them with the document body?


\documentclass[12pt,headings=normal]{article}
\usepackage{amsfonts, amsmath, amssymb}
\usepackage[margin=1in]{geometry}
\usepackage[hebrew,english]{babel}
\usepackage{general}
\begin{document}
We see \cite{hs}.
\bibliographystyle{alpha}
\bibliography{references}
\end{document} 

My BibTeX file has this:

@ARTICLE{hs,
  AUTHOR = {Yonatan Harpaz and Tomer Schlank},
  TITLE = {Homotopy Obstructions to Rational Points},
  YEAR = {2011},
  NOTE = {arXiv:1110.0164 [math.AG]},
} 
| improve this question | | | | |
  • I'm not sure I understand what you mean by "they are slightly shifted to the left from the rest of the text". By "they" do you mean the labels of the bib entries? Do you want the entire entry, and not just the first line, to be set to the full width of the textblock? – Mico Nov 5 '13 at 22:28
  • Yes. I just want all the entries to be the same margin as the text. Right now, the text is 1in from the boundary of the page, whereas the bibliography is less than one inch from it. – a25bedc5-3d09-41b8-82fb-ea6c353d75ae Nov 5 '13 at 22:37
  • The problem is that there is 1 inch from the leftmost text to the left boundary of the page, whereas there is less than one inch from the bibliography items to the left boundary of the page. – a25bedc5-3d09-41b8-82fb-ea6c353d75ae Nov 5 '13 at 22:56
  • Hmmm, looks like you've come across an incompatibility between babel -- specifically, its hebrew-related code -- and the alpha bibliography style. (The incorrect indentation goes away if the hebrew option is removed, but that's not a real solution, right?!) I'm afraid I have no suggestion for fixing this bug. – Mico Nov 5 '13 at 23:08
  • Thanks! Problem Solved! (There was actually no hebrew) Now to deal with tex.stackexchange.com/questions/142467/… – a25bedc5-3d09-41b8-82fb-ea6c353d75ae Nov 5 '13 at 23:34

Browse other questions tagged or ask your own question.