8

I'm having problems with my latex installation on Ubuntu 13.10. Have been using it successfully for a while on Ubuntu 13.04, after I updated bibtex doesn't seem to work.

The error I get is:

This is BibTeX, Version 0.99d (TeX Live 2013/Debian)
The top-level auxiliary file: paper.aux
I found no \citation commands---while reading file paper.aux
I found no \bibdata command---while reading file paper.aux
I found no \bibstyle command---while reading file paper.aux
(There were 3 error messages)

I have removed all texlive packages from my system and re-installed texlive-full and kile without success.

Any ideas on how to solve this?

Thanks!

Edit1: Example of .tex file:

\documentclass[a4paper,10pt]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc} % File encoding, you should try to stick to utf8.

\usepackage{csquotes} % Needed for biblatex
\usepackage[maxnames= 10, minnames = 10]{biblatex} % Modern bibliography facilities (you may change style to numeric). change to old bibtex if you insist on using that.
\usepackage{booktabs}

\usepackage{mathtools} % All your math related needs
\usepackage{tikz} % Draw figures, required for cover page
\usepackage{subfig} % Subfloats

\addbibresource{bibliography} 

\title{}
\author{}

\begin{document}
\section{test}
Citation\cite{Pironneau1984}

\cleardoublepage
\printbibliography

\end{document}

And bibliography.bib:

@article{Pironneau1984,
author = {Pironneau, O.},
journal = {Springer-Verlag},
title = {{Optimal Shape Design for Elliptic Systems}},
year = {1984}
}

Solution:

I found a solution to this problem when you suggested running biber.

sudo apt-get install biber

and the bibliography started working again, even without the .bib extension. Not sure why I had to install it separately as it was working fine before.

Thanks for the suggestions @CV4, @Māris Ozols & @MMA!

As explained by @jon the default engine is now biber intead of bibtex which explains why the biber packages is needed.

  • 2
    I do not think that it has anything to do with Ubuntu. Please let us know the contents of your main file. I suspect that you did not put the commands to specify the relevant BibTeX files. And welcome to TeX.SE. – Masroor Nov 6 '13 at 13:36
  • Does the paper.aux file actually contain these commands? – Māris Ozols Nov 6 '13 at 13:45
  • @MMA Thanks! I have tried this on files I ran successfully just a few weeks ago and I'm unable to get the bibliography working. I added a shorter versions of the files above. I think I included all the relevant packages. – user39581 Nov 6 '13 at 14:01
  • @MārisOzols No paper.aux does not contain these commands. – user39581 Nov 6 '13 at 14:02
  • @user39581 I am not very sure, but I have a strong suspicion that the problem lies with the line \addbibresource{bibliography}. You specify a resource, which is not available. Change in syntax in the upgraded version? Because, when using \addbibresource (which was introduced in biblatex v1.2), files must be specified with their full name, including the extension. Please see this answer. – Masroor Nov 6 '13 at 14:26
8

You are using biblatex instead of regular bibtex. That means two things:

  1. You have to specify file extension when you add the *.bib file: \addbibresource{bibliography.bib}.
  2. You have to call biber paper from command line to compile the bibliography.

After that, just compile your paper again and see if it works.

4

You are using biblatex, then you have to define a backend for biblatex. I think you have to see a warning at compiling like this: Package biblatex Warning: No "backend" specified, using Biber backend.

So I think the best way will be configuring your Editor (kile, if I read right) to use biber as processor for your bibliography. Your compile-chain will be then:

pdflatex paper.tex -> biber paper -> pdflatex paper.tex -> pdflatex paper.tex

Further you can clearly define biber as your biblatex backend by adding the option

backend=biber

to \usepackage[...]{biblatex}.

Please also think about defining the bibencoding, like you specify your inputenc, by passing option

bibencoding=utf8

to the same \usepackage command.

  • Thank you for the suggestions! I didn't get the warning but I have added the options as you suggested! – user39581 Nov 6 '13 at 14:57
1

Don't forget that you still can use BibTeX if needed or so desired; the default engine is now biber, so it defaults to that if you don't make an explicit declaration, but you could have this in your preamble:

\usepackage[backend=bibtex, % <--
  maxnames=10, minnames=10]{biblatex}
\addbibresource{bibliography.bib}

and, after begin{document}, the standard

\printbibliography

Then you compile with the normal (or 'old') tool chain:

latex  file.tex
bibtex file.aux
latex  file.tex
latex  file.tex

And things will work normally unless you use a (biblatex) bibliography style that specifically requires biber as the engine.

  • I see. That explains why I needed to install it separately. – user39581 Nov 6 '13 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.