1

I am using XeLaTeX in TeX Live suites 2010 and everything was going well before I did an upgrade via TeX Live Manager minutes ago. Now every document I compile gets a "File not found" error as the title suggests. But actually fontspec.sty is lying well under texlive\2010\tex\latex\fontspec so I don't understand why it complains about that.

Does anyone have the same situation?

4
  • @user4457: A suggestion: Change your username to something more telling than "user4457".
    – lockstep
    Mar 26, 2011 at 12:59
  • 1
    @user4457. Perhaps something went wrong with the update. Could you try sudo texhash at the Terminal and see if that helps (it rebuilds the file database).
    – Joseph Wright
    Mar 26, 2011 at 13:43
  • @lockstep, nice to meet you, I am ziyuang. @Joseph-Wright, But I am using Windows. @Martin-Scharrer, thanks for refining my question.
    – Ziyuan
    Mar 26, 2011 at 14:46
  • Nice to meet you, too. I started as "user510". ;-)
    – lockstep
    Mar 26, 2011 at 14:50

1 Answer 1

3

OK, I fixed it. Just copy the folder texlive\2010\tex\latex\fontspec to texlive\2010\texmf-dist\tex\latex\fontspec. There will be some other similar errors though. If it said "! Package graphics Error: No driver specified.", copy texlive\2010\tex\latex\latexconfig\graphics.cfg to the folder texlive\2010\texmf-dist\tex\latex\graphics. If it still doesn't work, do some database refresh job in tlmgr.

1
  • ziyuang, @Martin's suggestion is a good one; however, you'll have to wait about 14 more hours before you can accept your answer (as far as I know). Mar 27, 2011 at 20:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .