When using the backend=biber option, I get a warning:

package Biblatex warning: Please (re)run Biber on the file: (biblatex) myproject

Result: References are not recognized.

  1. Yes. A similar question does exist - but no solution is provided: Problem getting biber/biblatex/XeLaTeX/TeXworks working together.

  2. biblatex in a nutshell (for beginners) - as a MWE.

backend=bibtex works like charm.

Question: What are the detailed steps to get backend=biber working? (When people say run that command or another there is a need of context.)

So my editor is TeXnicCenter.

And I have no clue how to run Biber on my file under TeXnicCenter... or any other environment.

Consider me as a simple mortal that really would like to get this solved, save forever and never come back again.

In TexnicCenter I don't have to do anything fancy with the MWE using backend=bibtex except creating a .bib file. Then I press Build current file - and get valid pdf with my references, which is a way it should be - simple and concise. If there is a tendency to recommand biber for utf-8 support, then we should get fast deployment so this will be adopted faster.

The problem inherently is the same as this one: How to use biber.

  • What do exactly mean with "context" in the 'Question' part? Does your last sentence state, that your question is a dublicate or a special case of the mentioned post? – Ruben Nov 9 '13 at 1:04
  • It indicates that: 1. I found no solution with step by step guidance on how to make it work - in general(and i feel it has nothing to do with the .tex code/declarations - all the MWEs using biber don't work for me. 2. And if the solution is known then I would like to know which steps I have to go through in order to make it work within TexnicCenter. Thanks for editing. – Aubergine Nov 9 '13 at 1:31
up vote 9 down vote accepted

I would create a new build profile, say LaTeX > PDF (Biber), which is a copy of LaTeX > PDF (the one set up by default in TeXnicCenter):

enter image description here

Now add biber as the BibTeX compiler:

enter image description here

In the above "Command line arguments to pass to BibTeX", %tm refers to the file "Title (without extension)". You can also add other arguments to want to pass to biber here (like the file encoding, for example). For all options, see the biber documentation.

Now you can compile (no output) your document once under the LaTeX > PDF (Biber) profile and a second time under the LaTeX > PDF profile. In sequence, this performs a pdflatex > biber > pdflatex compilation. If you wish to do this in one click, you can add the following to the LaTeX > PDF (Biber) profile's Postprocessor tab:

enter image description here

The pdflatex process arguments are copied from the main profile page.

Running the following MWE:

\documentclass{article}
\usepackage{filecontents}% http://ctan.org/pkg/filecontents
\usepackage[backend=biber]{biblatex}% http://ctan.org/pkg/biblatex

\begin{filecontents*}{references.bib}
@article{mybibkey,
    author = {A. Author},
    title = {Some amazing work of art},
    journal = {A fur realz journal},
    volume = {17},
    number = {3},
    year = {2013},
    pages = {1--99}
}
\end{filecontents*}
\addbibresource{references.bib}

\begin{document}
See~\cite{mybibkey}.

\printbibliography

\end{document}

under LaTeX > PDF (Biber) with the added Postprocessor pdflatex component yields the one-click output

enter image description here

I would suggest keeping separate output profiles, since you only need to compile with biber once you have a change of bibliographic items, so you don't need to do it with every compile.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.