I'm running TeXnicCenter 1.0 and have just started in LaTeX. I have managed to get text in, get a lot of the formatting commands working and have rendered to pdf. It's awesome. My problem is packages, specifically wasysym. I have been googling and tried:

  • placing wasysym.sty in C:\Program Files (x86)\MiKTeX 2.8\tex\latex\wasysym
  • placing wasysym.sty in the folder containing the document file
  • running Refresh FNDB from mo.exe - I get a permission denied error.

No matter what happens, whenever I try to render a file containing \usepackage{wasysym} it refuses to render. I don't know enough about the error messages to work out what's happening. Can someone please help?

PS I don't have trouble with standard/built-in packages like parskip etc. Just when I tried to install wasysym it threw a tantrum.

  • 1
    According to the MiKTeX list of packages wasysym comes with MiKTeX: miktex.org/packages/wasysym; did you try using the Package Manager to install the package automatically? – Gonzalo Medina Mar 27 '11 at 1:49
  • It wasn't working automatically, so, assuming it wasn't a standard package, I went to CTAN and downloaded it. After a bit of playing around with the ins file I got the .sty and placed it in the two places mentioned above. I get a fatal error every time I un-% the line calling the package. – JackSprat Mar 27 '11 at 1:56
  • 1
    One option would be to carefully remove the file(s) that you manually installed and then use the Package Manager from MiKTeX: here's the manual: docs.miktex.org/manual – Gonzalo Medina Mar 27 '11 at 2:08
  • Specifically, this could be useful: Working with the Package Manager: docs.miktex.org/manual/pkgmgt.html – Gonzalo Medina Mar 27 '11 at 2:15
  • Don't use texniccenter if you want to install missing packages on-the-fly. texniccenter blocks the installation. Use e.g. for one compilation texworks (which comes with miktex). You can also use the package manager to install packages. Beside this: for a manual installation it is not enough to install wasysym.sty, you need also the font (tfm, pfb-files) and you must activate the map-file. At last: if you get an error message you should copy it in your question. You may not know what it means - we do. – Ulrike Fischer Mar 27 '11 at 8:46

As @Gonzalo Medina has pointed out, wasysym is included im MiKTeX. Even if it wasn't, you should not manually place files in C:\Program Files (x86)\MiKTeX 2.8 -- either use the package manager, or place all necessary files in your working folder (as a temporary solution) or a local TEXMF tree.

One possible reason for the "permission denied" error you mentioned is that your operating system is Windows 7 and you try to run the package manager and/or the FNDB refresh as normal user. Run it as administrator instead -- this option should be selectable under (Right-click) Properties/Compatibility. (Those may not be the exact labellings -- I'm using a German Win7.)

  • OK thanks. Looks like I have a few things to try. – JackSprat Mar 27 '11 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.