I recently obtained the MathTimes Pro 2 font from PCTex, and I'm having some trouble getting it to work; I use MacTex 2010.

I've blindly followed the instructions posted on PCTex here: http://www.pctex.com/kb/74.html

However, when I attempt to use the package, I get the following error message:


Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(./Fonts.aux) [1{/usr/local/texlive/2010/texmf-var/fonts/map/pdftex/updmap/pdft
ex.map}] (./Fonts.aux)
kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 mt2syt
mktexpk: don't know how to create bitmap font for mt2syt.
mktexpk: perhaps mt2syt is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.
!pdfTeX error: /usr/texbin/pdflatex (file mt2syt): Font mt2syt at 600 not found

 ==> Fatal error occurred, no output PDF file produced!

I've searched relentlessly for a solution, but I can't seem to find one (or make one work). Does anyone have any ideas?

  • It's difficult to answer without the exact same system and the files from PCtex. However, it sounds to me as though something went wrong when you ran updmap-sys. Try running updmap-sys again, this time without any options. Look for mentions of mtpro2.map in the output. What do you find? – Ian Thompson Mar 27 '11 at 20:13
  • Ok, I got it. The problem did have something to do with the updmap-sys command. I had to copy the .map file, in this case mtpro2.map, to the folder /usr/local/texlive/texmf-local/web2c. I'm still not entirely sure why this fixed the problem; I just played around with a few commands while looking at mactex-wiki.tug.org/wiki/index.php?title=Font_Installation. – Nick Strehlke Mar 27 '11 at 22:48
  • It sounds like my question was poorly posed; what is the proper etiquette if I've found the solution? Should I delete the question or post my answer? – Nick Strehlke Mar 27 '11 at 22:50
  • In situations like this, where you asked a genuine question and then happened to find the answer yourself, it's perfectly acceptable to post your own answer and accept it. Although the problem was specific to your system and the font files that you purchased, other users may find the discussion of updmap-sys useful. – Ian Thompson Mar 28 '11 at 17:45

Usually you should not copy the map file to the web2c directory. web2c is for use of configure files, for example updmap-local.cfg.

Usually map files go to fonts/map or fonts/map/dvips.

Your original problem seems to be that you didn't run mktexlsr before updating the updmap database. This caused the updmap cannot find the required map file. I don't know if texhash has any effect today though it is suggested in the PCTeX's website.

Anyway, you solved the problem yourself, and I think it is because as long as updmap can find the the map file, either in fonts/map, where it should be, or in web2c, it is ok. But it is still better to keep files where they are supposed to be. See the documentation for TDS.

Just a tip may be useful. I create a file updmap-local.cfg in /usr/local/texlive/texmf-local/web2c which contains the name of the map files in /usr/local/texlive/texmf-local/fonts/map. Since I got quite a few fonts installed in texmf-local, it is more convenient to keep a record of all map files. If say, I reinstalled the MacTeX, and the /usr/local/texlive/2010 folder is completely overwritten. All I need to do is

sudo mktexlsr
sudo tlmgr generate updmap
sudo updmap-sys

As long as my texmf-local folder does not change. Thus I don't have to type udpmap-sys --enable ... where ... can get quite long and error prone.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.