I am a total novice with no TeX or programming experience, trying to learn how to use LaTeX in general, but specifically attempting to use the 'chemstyle' package, so as to allow for automated numbering of my chemical compounds when drawn in ChemDraw and saved as '.eps' files containing temporary labels of 'TMP'.

I am currently using MikTeX and TexStudio (also have TeXworks) and have attempted both manually installing the chemstyle package from CTAN and directly from the MikTeX repository with no apparent difference between the two.

I have been using the tutorial here and typing the lines below in my preamble:


I can't remember where I got it from but the inclusion of "crop=off" eliminates an intial error of:

pdfcrop: The Perl interpreter could not be found.
Process exited with error(s)

I have also attempted to enable shell escape in the command line, I think successfully, as I've read in a few places that it's necessary with this package.

Unfortunately whether I use my own file or the example ones given in the tutorial, the file never compiles successfully and I get a lot of error messages concerning 'caption3.sty' such as:

Command \caption@ifinlist already defined. \@expandtwoargs\caption@@ifinlist}

as well as a warning about 'typearea.sty'.

Below is a basic version of my document:







\fancypagestyle{main}{ %





\title{\TitleFont Thesis}
\author{A Name}





Some thanks.


An abstract.


This is the glossary...



Here is the introduction.

\markedsection{Sec1}{First Section}

\subsection{First Subsection}

\subsubsection{First Subsubsection}




Thank you in advance for any help you can give and apologies if I've left out any necessary information.

Edit: The output message following an attempt to compile is as below.

Process started: "C:\Program Files\MiKTeX 2.9\miktex\bin\pdflatex.exe" -synctex=1 -interaction=nonstopmode "chemstyle".tex

This is dvips(k) 5.992 Copyright 2012 Radical Eye Software (www.radicaleye.com) ' TeX output 2013.11.12:1417' -> chemstyle-autopp.ps <C:/Program Files/MiKTeX 2.9/dvips/base/tex.pro> <C:/Program Files/MiKTeX 2.9/dvips/misc/alt-rule.pro> <C:/Program Files/MiKTeX 2.9/dvips/psfrag/psfrag.pro> <C:/Program Files/MiKTeX 2.9/fonts/enc/dvips/libertine/lbtn_c7kyj5.enc> <C:/Program Files/MiKTeX 2.9/fonts/enc/dvips/libertine/lbtn_s5bq4i.enc> <C:/Program Files/MiKTeX 2.9/fonts/enc/dvips/libertine/lbtn_c6xmqr.enc> <C:/Program Files/MiKTeX 2.9/fonts/enc/dvips/libertine/lbtn_xogrpz.enc> <C:/Program Files/MiKTeX 2.9/fonts/enc/dvips/libertine/lbtn_p657rp.enc> <C:/Program Files/MiKTeX 2.9/dvips/base/texps.pro> <C:/Program Files/MiKTeX 2.9/dvips/base/special.pro> <C:/Program Files/MiKTeX 2.9/dvips/base/color.pro>.

<C:/Program Files/MiKTeX 2.9/fonts/type1/public/libertine/LinBiolinumT.pfb> <C:/Program Files/MiKTeX 2.9/fonts/type1/public/libertine/LinBiolinumTB.pfb> <C:/Program Files/MiKTeX 2.9/fonts/type1/public/libertine/LinLibertineTI.pfb> <C:/Program Files/MiKTeX 2.9/fonts/type1/public/libertine/LinLibertineT.pfb> <C:/Program Files/MiKTeX 2.9/fonts/type1/public/amsfonts/cm/cmr12.pfb>[1] [1] [2] [3] [4] [5] [6] [7] [1] [2]

Process exited with error(s)
  • MikTeX does not provide a perl interpreter, so you have to install one, activestate.com/activeperl ought to be enough. Had you chosen to use TeX Live to begin with, then pdfcrop would work out of the box as a Perl interpreter is included in TeX Live on Windows. – daleif Nov 11 '13 at 16:04
  • Since you're using geometry you can simply ignore the typearea warning. I am unable to reproduce the caption errors with your MWE, though... – cgnieder Nov 11 '13 at 16:57
  • Thanks daleif, that eliminates the Perl error without including 'crop=off'. – ChemStu Nov 12 '13 at 14:31
  • Thanks cgnieder for the tip about 'geometry', I suspect the issue relates to an incorrect setting somewhere as the tutorial files also give the same errors - I'm updating my entry to include the message I get in case that's of any use to unpicking the problem. – ChemStu Nov 12 '13 at 14:34
  • 4
    This question appears to be off-topic because it is about a problem due to an outdated package (caption). – egreg Dec 21 '13 at 17:52

Thank you again to everyone for their input above. Credit for resolving what proved to be quite a specific problem goes to author of the 'chemstyle' package himself, Joseph Wright.

An old version of 'caption.sty' was hidden in a template package installed in the root texmf tree - simply deleting this allowed correct compilation of all test files.

The conflicting package was identified by looking through the '.log' file for where packages relating to the errors (in this case 'caption') were loaded from.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.