3

Im trying to confing my Lyx to render Hebrew but I dont manage. I have a fresh installation of Ubuntu 13.10, Lyx 2.0.6. I followed these common instructions , downloaded and installed the latest version of culmus (culmus-latex_0.7-1_all_fixed) as required but got warnings from the software centre:

The package is of bad quality

and in details some of this type

E: culmus-latex: control-file-has-bad-owner postrm itai/itai != root/root

And alot of this type

E: culmus-latex: wrong-file-owner-uid-or-gid etc/ 1000/1000 " I tried the ignoring and installing anyway, but the lyx still wasnt showing hebrew. I tried also installing "culmus-latex-0.7-r1.tar.gz" (which i managed to install without errors) I also installed "TrueType and Type1 Hebrew Fonts for X11" from the software centre.

Normally after configuring the setting and preferences the system language remains English but when typing in Lyx the Hebrew letters appear but now i cant get it to work.

  • I remember there is a need to change the cua file in Tools -> Preferences -> Edit -> shortcuts into a special hebrew cua bind file and then be able to set F10 to switch the Hebrew and English (which one of them appears with an underline), but I did no such thing. at this moment F10 only switches the direction of the typing - RTL\LTR
  • When I try to render an empty document to PDF after applying those changes I get the error: "LaTeX Error: File `cp1255.def' not found" where cp1255 is of course the Hebrew encoding i chose in the document settings.

This is all the information I have Thank you for all the help.

2

You can get support for compiling with pdfTeX and IvriTeX Hebrew fonts by using install-tl-ubuntu. Just run the following command:

sudo ./install-tl-ubuntu --hebrew

Before you do that, you should remove whichever LaTeX installation you currently have (by default it installs a full TeX Live 2013 distribution). See ./install-tl-ubuntu --help for more information.

If you would like to compile with XeTeX, there is no need for any of this. Just to test that it works (the choice of fonts is not correct and probably ugly for Hebrew but you can use any fonts):

  1. In Document > Settings > Fonts, check the box "Use non-TeX fonts" and change the three fonts to FreeSans (or any other font that supports Hebrew).
  2. Click OK.
  3. Try to export with XeTeX.

Better Hebrew fonts can be found in the ubuntu packages culmus and culmus-fancy.

  • I have removed the latex by using the command " sudo apt-get remove texlive-*", installed the tl-ubuntu and not lyx doesnt compile in any language, I get the error "File does not exist: /tmp/lyx_tmpdir.J21775/lyx_tmpbuf4/newfile2.pdf" – Pear Nov 12 '13 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.