If I try to compile with the LuaLaTeX-compiler in TeXnicCenter with the below outputprofile-settings, there showing up this error:
[ForwardSearch("%bm.pdf","%Wc",%l,0,0,1)] Cannot execute the command

It seems, that my viewer doesn't accept the command for forward search.

I have just run the wizzard for ouputprofiles. This has configured the settings in the "LuaLaTeX->pdf" profile as follows:


  1. Path to compiler: C:\Program Files\Miktex\miktex\bin\x64\lualatex.exe
  2. Command line arguments: -synctex=-1 -interaction=nonstopmode "%wm"


  1. Executable path: C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Program Files\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto('%f','%l')]\""
  2. View projects's output
    Command line Argument
    Command: "%bm.pdf"
  3. Forwardsearch
    DDE command
    Command: [ForwardSearch("%bm.pdf","%Wc",%l,0,0,1)]
    Server: sumatra
    Topic: control
  4. Close document before running
    Do not close

The problem exist only for the "LuaLaTeX->pdf" profile. The "Latex->pdf" still keeps working good.

Maybe there is an lualatex- and texniccenteruser outhere, who can have look in his settings for a comparison with my settings?

I use:

  • Texniccenter 2.02 Stable (64 bit)
  • SumatraPDF v2.4

Any ideas or suggestions?

  • 1
    Welcome to TeX.sx! This error is only about opening a file. Was it created in the folder?! Is the executable path for your viewer is OK at Build/Define output profile/LuaLaTeX->pdf/viewer? – masu Nov 12 '13 at 2:23
  • What do you mean with: Was it created in the folder? I simply try to compile a created minimal helloworldprojekt. I think the viewerpath is OK. Like I said, with normal latex-code and normal latex-compiler every thing works fine. If I try to compile with preset "LuaLateX->pdf" profile or if I try to make a new Profile, like described above, I get the described error. Does anybody know how to compile lualatex with TeXnicCenter? – overstack Nov 18 '13 at 17:49
  • After the installation of »Sumatra PDF« you can try to rebuild the profiles by pressing "Alt+F7" and starting the wizard. TXC2 prefers Sumatra over the AR and does the correct settings. I don't have any problems with the default settings. – Thorsten Donig Nov 18 '13 at 19:05
  • I have followed your instruction. You can see the result in the edit above. – overstack Nov 19 '13 at 12:57
  • Try [ForwardSearch("%bm.pdf","%Wc",%l,0,0,0)] in the command box of the viewer tab – Mario S. E. Nov 19 '13 at 17:49

I have the same problem. In addition, I saw that lualatex does not produce a synctex.gz file. therefore, the forward search commando can not be executed.

I was able to solve the problem, by changing the Option "Command line arguments to pass to the compiler" (On the tab (La)Tex of the profile) to

-interaction=nonstopmode --synctex=1 "%Wm"

especially, note the additional - before synctex.

Afterwards, forward search works for me.

| improve this answer | |

I'm using TeXnicCenter and I have no problem with this config on the viewer tab, as described in How to configure TeXnicCenter 2.0 with Sumatra (2013--2016 version) ---the rest of the settings are just like yours:

View projects's output

DDE command

Command: "%bm.pdf"

server: SUMATRA

Topic: Control

Forward Search

DDE command

command: [ForwardSearch("%bm.pdf","%Wc",%l,0,0,0)]

server: SUMATRA

Topic: control

| improve this answer | |

Thx for all answering, but none of the answers solves the problem. Just the following procedure brings a solution: Deinstalled Sumatra, Texniccenter and Miktex. Removed the folders from Sumatra and Miktex in 'C:\Users\username\AppData\Roaming'. Running Piriform-Registrycleaner. Running Wise-Registrycleaner. Installed first Miktex to an other direction as before. Then installed Sumatra and after this Texniccenter (note the order of installing the programms!).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.