How can I introduce, as embedded subsets, the fonts: Symbol, Times-Bold,Times-Roman, TimesNewRomanPSMT-Bold, TimesNewRomanPSMT-Bolditalic in Plain TeX, under Ubuntu?


3 Answers 3


It should be possible with ps2pdf.

After generating a PS file, I have used the following script for creating a PDF with embedded fonts:

ps2pdf \
-dCompatibilityLevel=1.4 -dCompressPages=true \
-dUseFlateCompression=true -dSubsetFonts=true -dEmbedAllFonts=true \
-dProcessColorModel=/DeviceGray -dDetectBlends=true -dOptimize=true \
-dColorImageFilter=/FlateEncode \
-dAutoFilterColorImages=false -dAntiAliasColorImages=false \
-dColorImageDownsampleThreshold=1.50000 \
-dGrayImageFilter=/FlateEncode -dAutoFilterGrayImages=false \
-dAntiAliasGrayImages=false -dGrayImageDownsampleThreshold=1.50000 \
-dDownsampleMonoImages=true -dMonoImageResolution=1200 \
-dMonoImageDownsampleType=/Average -dMonoImageFilter=/FlateEncode \
-dAutoFilterMonoImages=false -dAntiAliasMonoImages=false \
-dMonoImageDownsampleThreshold=1.50000 \
-dEPSCrop=true \
$1 $2

The magic words would be -dSubsetFonts=true -dEmbedAllFonts=true

  • OK, but the anove mentioned fonts are not shown as being embadded. It this a problem with Adobe Reader 9? Nov 12, 2013 at 17:21
  • I would rather suspect that it's a problem with ps2pdf. If you can share a copy of the generated PDF, we could also check if the fonts are there. Otherwise, did you try Martin Schröder's answer below? Nov 14, 2013 at 7:47
  • How else can I verify the embedded fonts, except for Adobe Reader 9? I tried several methods, but the result is always the same, i.e. NOTHING added. Thank you! Nov 16, 2013 at 8:09
  • You could try it with Okular too. Under File/Properties/Fonts, it should say "Embedded (subset)" for your fonts. If not, I'm not sure how to help you. Nov 18, 2013 at 6:59

I don't have enough rep to comment, but:

For Windows, Supernormal's answer will not work. Apparently ps2pdf (at least the version of ps2pdf I have) requires # instead of =, so anyone telling you to write something along the lines of this:

‐dPDFSETTINGS=/printer  ‐dMaxSubsetPct=100  ‐dSubsetFonts=true ‐dEmbedAllFonts=true

For Windows it should be like this:

‐dPDFSETTINGS#/printer  ‐dMaxSubsetPct#100  ‐dSubsetFonts#true ‐dEmbedAllFonts#true

That worked for me.


Your TeX system can be configured so that all pdf producing apps (pdftex/xetex/luatex and dvipdfmx) always embed the standard 14 PDF fonts into PDFs by issuing updmap-sys --setoption pdftexDownloadBase14 true (for pdftex/xetex/luatex) and to always embed the standard 35 PostScript fonts by issuing updmap-sys --setoption dvipsDownloadBase35 true (for dvips).

  • Is this also possible for pdflatex? Thx. Mar 18, 2014 at 16:02
  • 1
    @ManuelKuehner: Yes. See the updated question. Mar 18, 2014 at 16:57

Not the answer you're looking for? Browse other questions tagged .