6

MWE:

\documentclass[english]{scrreprt}

%%% PAGE DIMENSIONS
\usepackage{geometry} 
\geometry{verbose,a4paper,tmargin=3.5cm,bmargin=2.5cm,lmargin=2.6cm,rmargin=2.6cm,headheight=1.3cm,headsep=1cm}
\pagestyle{headings}

%%% PACKAGES
\usepackage{array}
\usepackage{paralist}
\usepackage{verbatim}
\usepackage{subfig}
\usepackage{amsmath, amsthm, amssymb, url}
\usepackage{enumitem}
\usepackage{mathrsfs}
\usepackage[english]{babel}
\usepackage[T1]{fontenc}
\usepackage[latin9]{inputenc}
\usepackage{tabu,longtable,booktabs,caption}
\usepackage[pdftex]{graphicx,color}
\usepackage{scrpage2,datetime,tikz}
\usepackage{hyperref}
\usepackage[nottoc,numbib]{tocbibind}
\usepackage{bookmark}
\usepackage[toc,page]{appendix}

%%% OPTIONS
\bibliographystyle{plain}
\setcounter{secnumdepth}{3}
\setlength{\parindent}{1em}
%\setlist{nolistsep}
\tabulinesep=^1.5mm_1.5mm
\tikzset{>=latex}
\hypersetup{
    colorlinks,
    citecolor=black,
    filecolor=black,
    linkcolor=black,
    urlcolor=black
}

%%% DEFINITIONS
\newenvironment{myfont}{\fontfamily{phv}\selectfont}{\par}
\renewcommand{\dateseparator}{.}
\DeclareMathOperator{\sgn}{sgn}
\DeclareMathOperator{\Wrap}{Wrap}
\addto\captionsenglish{  \renewcommand{\contentsname}  {Table of Contents} }

%%% HEADERS
\makeatletter
\pagestyle{scrheadings}
\setkomafont{pagehead}{\sffamily\bfseries\small }
\clearscrheadfoot
\rohead{line1 \linebreak \@normalcr[-9pt] line2 \linebreak\@normalcr[-2pt] \normalfont\sffamily\footnotesize{line3 \linebreak\@normalcr[-49pt]}}
\lohead{\rule{1.5cm}{1.5cm}\vspace{0.05cm}}
\setheadsepline{0.4pt}
\makeatother

%%% FOOTERS
\lofoot [docname.pdf] {docname.pdf}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\begin{document}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\pdfbookmark[section]{\contentsname}{toc}
\tableofcontents 

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\chapter{chapter}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\begin{appendices}
\chapter{appendix1}
\end{appendices}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\bibliography{mybib}

\end{document}

I end up having "Bibliography" as second chapter.

How can I prevent it? Have I messed up something with those packages?

9

Option 1: replace

\usepackage[nottoc,numbib]{tocbibind}

with

\usepackage[nottoc]{tocbibind}

See section 2 of the tocbibind documentation in case numbib is not self-explanatory.

Option 2: As you're using a KOMA-Script class, don't load the tocbibind package at all; instead add the class option bibliography=totoc.

| improve this answer | |
  • perfect, thank you very much! :) (used the second solution, btw) – Federico Nov 12 '13 at 11:18
  • Option 3: The class option toc=bib (KOMA-Script 3.11b). – Thorsten Donig Nov 12 '13 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.