I would like to install and use the xcharter package, but am unclear on the steps involved. There are what appear to be instructions provided with the package, but I don't understand them.

Is it sufficient to install the package using Tex Live Utility (on OS 10.9), or are there additional steps required to build and place fonts in various directories? Will the installation disturb any existing fonts?

  • 1
    Using Tex Live Utility (or tlmgr) to install xcharter should suffice and cause no problems.
    – DG'
    Nov 12, 2013 at 18:04
  • @DG': Do I need to run anything after Tex Live Utility, or is that sufficient?
    – orome
    Nov 12, 2013 at 19:16
  • You should be good to go.
    – DG'
    Nov 12, 2013 at 19:19
  • @DG': Generalized a bit to the steps needed to install a package that includes fonts, this could be an accepted answer.
    – orome
    Nov 12, 2013 at 19:25
  • Note that installing xcharter gets around a bug in mathdesign.
    – orome
    Nov 14, 2013 at 22:56

2 Answers 2


As far as I can see there are four different cases. The first three cases concern fonts with direct LaTeX support (there are packages) with different licenses, while the fourth addresses fonts without direct LaTeX support, no matter how they are licensed:

a) Free fonts in the TL repository like xcharter

On a well maintained, recent distribution like TL2013 on MacOS it is very likely, that simply updating your system with the TeX Live Utility will install everything needed.

If you don’t have a full installation, just install the package with TeX Live Utility or by running sudo tlmgr install xcharter in a terminal. (The instructions on font installation, which are often found in the documentation of font packages, are only of import if you are not using a package manager.)

This applies to a whole range of fonts like dejavu, utopia, libertine, mathpazo and gentium to name just a few.

b) Non-free fonts like garamondx

There is a number of fonts, including garamondx, which can be installed using the script getnonfreefonts. In order to do so, follow the instructions here.

c) Non-free fonts with LaTeX support like Minion Pro

Other popular fonts like Minion Pro have LaTeX support but need to be installed manually. Usually there are detailed instructions accompanying the packages. In some cases, like Minion Pro, you can even find scripts that do the work for you.

d) Fonts without direct support

There is a huge class of commercial and free fonts without direct LaTeX support. They can be used with fontspec (this option requires XeLaTeX or LuaLaTeX).

More on manual font installation here.

So, to generalize a bit: if a package contains a font and the package is in the TL repository then installing it with a package manager (like tlmgr) should suffice.

  • Actually, this doesn't work after all, I get "! LaTeX Error: Font family 'T1+XCharter-OsF' unknown." if I have \usepackage[scaled=.96,osf]{XCharter} (taken directly from the documentation) in my document. It doesn't look as of the fonts are being found after all.
    – orome
    Nov 14, 2013 at 3:59
  • Sorry to hear that. The installation of xcharteris straight forward, so I suspect the error lies elsewhere. Try the following steps to figure out, what went wrong: 1. Update your installation: sudo tlmgr update --all --self. 2. Reinstall xcharter: sudo tlmgr install --reinstall xcharter. 3. Run: sudo updmap-sys --syncwithtrees.
    – DG'
    Nov 14, 2013 at 7:53
  • My bad: My issues had nothing to do with the xcharter installation and everything do to with some lines in my template that messed with bolding (e.g.: \DeclareFontShape{\encodingdefault}{\rmdefault}{sb}{n}{<->ssub*\rmdefault/bx/n}{}). If I remove those lines charter works. I'm not sure what I've lost by removing them, but I don't see anything at first glance.
    – orome
    Nov 14, 2013 at 22:55
  • 1
    Glad to see the mystery solved. The code you are mentioning seems to redefine bold as semi bold, which results in error as there is no semi-bold charter.
    – DG'
    Nov 15, 2013 at 11:07
  • Prior to installing xcharter, this redefinition worked, with the same mathdesign options I'm using now ([charter, expert,euro].I would like to have semi-bold replace bold. Why did it work before and not now?
    – orome
    Nov 15, 2013 at 14:31

To install the xcharter font for Texlive, I did the following (I'm using Ubuntu 14.04 LTS):

  1. Download the TDS-structured trees for the font packages from CTAN, e.g. xcharter.tds.zip. Unzip it to your personal directory $TEXMFHOME or system directory, i.e.:

    unzip -d xcharter.tds.zip ~/texmf/

  2. Update the database (no root, no sudo), i.e.:

    texhash ~/texmf/

  3. Update the font-map files by enabling the Map file XCharter.map:

    updmap -enable MAP=XCharter.map

OR alternatively, manually edit your font-map file "updmap.cfg", in my case, it is located at ~/.texmf-config/web2c/updmap.cfg, just simply add a new line into the file:

Map XCharter.map

Done. In general, these steps would work for installing most of the latex fonts downloaded from CTAN into your TexLive system.

Keywords: latex, install fonts, ctan, ubuntu, texlive

Reference: https://www.tug.org/fonts/fontinstall-personal.html

  • the unzip command is wrong, the correct form is: unzip -d ~/texmf/ xcharter.tds.zip
    – Kasra
    Aug 4, 2021 at 1:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .