4

PROBLEM FIXED

The problem was found within the custom class I was using, {Latex/Classes/PhDthesisPSnPDF} as I was using the CUEDThesisPSnPDF template for my thesis. Within the class I searched for pagebackref in the hyperref package and just added "= false", so it now reads pagebackref = false,

I'm having a bit of trouble trying to remove the page number hyperlinks displayed after references in the bibliography, for example:

[39] E. Economou, Green's Functions in Quantum Physics. Springer, 3rd ed., 2006. 7, 26

I found on a previous answer that the usual culprit is

\usepackage{hyperref}

in the preamble, but after disabling this I still have the problem. I can't see any other reference package that might be enabling this option, but here is the preamble and the bit where I insert my refernces. I also tried changing reference styles but this didn't remove the page numbers either!

\documentclass[oneside,12pt]{Latex/Classes/PhDthesisPSnPDF}

\include{Latex/Macros/MacroFile1}

\usepackage{enumerate}  

\usepackage{amsmath}    

\usepackage[T1]{fontenc}

\usepackage{graphicx}   

%\usepackage{hyperref}

\usepackage{amssymb}

\usepackage{cancel}

\graphicspath{{./Images/}}

\usepackage{float}

\usepackage{subfigure}

\usepackage{sidecap}

\usepackage{caption}

.....

\bibliographystyle{ieeetr}

\bibliography{references}

\end{document}
  • 2
    What is lurking in Latex/Macros/MacroFile1? – Andrew Swann Nov 12 '13 at 19:19
  • Welcome to TeX.SX! You can have a look on our starter guide to familiarize yourself further with our format. – cmhughes Nov 12 '13 at 19:21
  • Just some macros for repeated insertion of figures etc, they aren't used in my code so I've removed them just now and my results are still the same. – Josh Nov 12 '13 at 19:33
  • Perhaps you should also remove hyperref option of biblatex package (for example : \usepacakage[style=authoryear-comp,hyperref]{biblatex}). You MWE is incomplet so I can see if you have this option or not. – ppr Nov 12 '13 at 20:16
  • Answers should preferably be posted as a an answer, not added into the question. Then you can also accept your own answer, which marks the question as solved. (You may have to wait a few hours before you're allowed to do that though.) – Torbjørn T. Nov 12 '13 at 21:20
3

Quoting the OP:

PROBLEM FIXED

The problem was found within the custom class I was using, {Latex/Classes/PhDthesisPSnPDF} as I was using the CUEDThesisPSnPDF template for my thesis. Within the class I searched for pagebackref in the hyperref package and just added "= false", so it now reads pagebackref = false,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.