Is it possible to put the list of figures and tables onto one page? I only have two tables in my thesis, so having it on an extra page looks quite bad.

I've read about the tocloft package and tried to use it. It moved both lists onto one page, but they're no longer shown in the table of contents.

So is there a way to get \listoffigures and \listoftables on the same page while preserving the ToC entry for them?

  • AFAIK in traditional typesetting the LoF and LoT (as well as the ToC itself) are not listed in the ToC. The explanation I got was that they have a fixed place (just after the ToC) and therefore do not have to be listed. The same counts for material with a fixed place at the end, like references. However, I can see why you would add them to an e.g. thesis: they aren't very common with other SW (like MS Word) and people might just indicate to e.g. the supervisor that they exist. Mar 29, 2011 at 14:54
  • Thanks for the quick response! All theses on my chair have a similar structure, so I don't want to skip something from the ToC that's usually there in other theses.
    – Bruno
    Mar 29, 2011 at 15:03
  • I see. (I put them into my undergrad thesis as well.) Mar 29, 2011 at 15:07
  • What class are you using for your thesis? Or did you use, anyway. Article doesn't add a newpage by default.
    – Canageek
    Mar 31, 2012 at 23:02

5 Answers 5


You can temporally disable the \clearpage (and/or \cleardoublepage) command which generates the page break at the beginning of the second \listof... command:


You might need to manually adjust the spacing before the second headline.

However without a minimal example that shows your used class and packages I can't test it. It works with the default book class, but then the LoF and LoT aren't added to the ToC in any case.

  • 2
    Works perfect in report. ToC also generates correctly. Thank you
    – chwi
    Jun 5, 2013 at 8:58
  • 1
    Works also perfect with scrbook. However, do not forget to put toc=listof as parameter into the \documentclass command. Without this parameter no \listof* entries are included in the toc.
    – phx
    Dec 6, 2013 at 8:03
  • 1
    It works perfectly for mitthesis. Yet, I need let both \clearpage and \cleardoublepage relax. :-) Apr 4, 2015 at 14:42
  • How do I do this "manual adjustment of the spacing before the second headline"? I tried both \vspace{5cm} and \bigskip but neither had any effect... Jan 8, 2019 at 17:57
  • @Christallkeks: This surprises me. Try \vspace*{...}. If this does not work, feel free to post a follow-up question with a minimal working example which shows your code so far. Please link back to this post if you ask the question. Jan 8, 2019 at 18:33

Just an afterthough. For documents with few tables and figures I usualy bundle them together in one command \listofillustrations

\providecommand\phantomsection{}% for hyperref

    \chapter*{List of Illustrations}%
    \addcontentsline{toc}{chapter}{List of Illustrations}%


If you are using an article class you can use \section* and \subsection*

  • I used Martins answer, but that's a really cool idea :)
    – Bruno
    Mar 31, 2011 at 9:29
  • I like that, but unfortunately it adds additional spacing between entries if parskip=half. I use scrbook.
    – letmaik
    Apr 10, 2013 at 13:05

memoir's default \listoffigures and \listoftables commands don't put themselves on separate pages:



Some fake content
\caption{A first fake figure}%

Some fake content
\caption{A second fake figure}%

More & fake & content
\caption{A first fake table}

More & fake & content
\caption{A second fake table}

Default memoir ToC, LoF, LoT

I won't go so far as to recommend memoir for everything, but if you're writing a thesis, and are already looking at tocloft and similar packages, you may end up piecing together a sizable portion of what memoir already provides in one class. I have a style for my university based on memoir, and the lines of code required to maintain the style requirements is easily half of what the previous style file had. How much of that improvement is due to memoir itself, and how much is from replacing old explicit code with newer CTAN packages, I can't say.


I actually did this a slightly different way.

Firstly add a manual chapter name, without number, then by letting the chapter = section, they are put on the same page as a section, as opposed to new chapter format.

\def\lofchaptername{Lists of Figures, Tables, Derivations Etc...}




%The next two are custom theorems defined elsewhere using amsthm and thmtools.


I use \documentclass{article} and just adding \usepackage[nottoc]{tocbibind} to the preamble worked for me :)

  • 1
    Please don't down vote without saying why.. it's so annoying. Jul 25, 2018 at 2:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.