4

I'm working with TeXworks. It has some auto completions but not enough. How can I add some auto completion to it. Is there any way to add them from TeXmaker to TeXworks.

  • 1
    Related: tex.stackexchange.com/questions/118038/texworks-auto-complete See also code.google.com/p/texworks/wiki/CodeCompletion I don't have time at the moment, but I (or anyone else who wants to) can write a better answer later. – Torbjørn T. Nov 15 '13 at 7:25
  • I read (tex.stack ... auto-complete). Then I went to D:\programs\texlive\texmf-config\texworks\completion and change the tw-latex.txt. I insert some codes for "bb" similar to "bf" everywhere then save and close it. But It doesn't work. – Hoseyn Heydari Nov 15 '13 at 8:52
  • What exactly did you insert? Was TeXworks open at the time? If so you need to restart it. – Torbjørn T. Nov 15 '13 at 8:59
  • mbb:=\mathbb{#INS#} before mbf:=\mathbf{#INS#} and \mathbb{#INS#}\mbb:=\mathbb{#INS#} before \mathbf{#INS#}\mbf:=\mathbf{#INS#} – Hoseyn Heydari Nov 15 '13 at 9:06
  • Hm, worked fine here, in Kubuntu. If you in TeXworks choose Scripts --> Scripting TeXworks --> Show Scripts Folder, do you get the folder D:\programs\texlive\texmf-config\texworks\scripts? – Torbjørn T. Nov 15 '13 at 9:19
4

I collocated these in my discussion with Torbjørn T and this answer to find my way:

  1. You should open your TeXworks, choose Scripts--> Scripting TeXworks --> Show Scripts Folder.
  2. Then you will achieve folder like "C:\Users\user\TeXworks\scripts". You should go to Folder "C:\Users\user\TeXworks\completion" instead.
  3. TeXworks stores the completion data in a series of files called "tw-<name>.txt" here. You can edit related file i.e. add your completion with Notepad or create a new one for your self.(The format of work and some more is detailed here.)
  4. Then save and close it, restart your TeXworks and enjoy new completions.
0

The problem with a build folder can be avoided by changing the Bib(la)tex option from bibtex % to bibtex build/%. This should also be done with all other output files in the fields dvisp, Dvipdfm etc. This worked for me at least.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.