4

I am new to Latex and I used multibib package and .bib file. Every thing works great except there is no DOI at the end of entities. All my entities in the bib file have DOI filed and url and I use unsrt and ieeetr styles in my bibliography subsections. I check this post but including doi package in Latex with multibib results in error Option clash for package hyperref. \begin{document} which I don't understand why? I also came up with the idea of editing biblatex.cfg by adding doi=true line to that file it does not work either (I don't know if i did it in correct way). I use x64 edition of MiKTeX 2.9 with BibTex and TexStudio 2.6.6. I want something that results in adding DOI to the end of my bib entities in the PDF with hyperlink like \newcommand*{\doi}[1]{\href{http://dx.doi.org/#1}{doi: #1}} automatically for my doi fields in bib file for unsrt and ieeetr styles.

As mentioned in comments I provide a minimal sample of the paper at following:

File: Ref.bib

@article{a1,
 author             = {Author1},
 title              = {Title1},
 journal            = {Journal1},
 issn               = {xxxx-yyyy},
 year               = {2013},
 volume             = {TR},
 number             = {3},
 pages              = {52-144},
 doi                = {10.10.1038/nphys1170},
 url                = {http://dx.doi.org/10.10.1038/nphys1170}
}

@article{a2,
 author             = {Author2},
 title              = {Title2},
 journal            = {Journal2},
 issn               = {xxxx-yyyy},
 year               = {2012},
 volume             = {k-8},
 number             = {6},
 pages              = {12-17},
 doi                = {10.1002/0470841559.ch1},
 url                = {http://dx.doi.org/10.1002/0470841559.ch1}
}

@inproceedings{c1, 
 author             = {Author3},
 title              = {Title3},
 booktitle          = {proceedings1},
 year               = {2012},
 pages              = {578-584},
 numpages           = {3},
 doi                = {10.1594/PANGAEA.726855},
 url                = {http://dx.doi.org/10.1594/PANGAEA.726855}
}

File: test.tex

\documentclass[]{article}

\title{Title Here}
\author{Name Here}

\usepackage{multibib}
\newcites{Articles,Proceedings}{{Journal Papers},{Conference Papers}}

\begin{document}
\maketitle

\begin{abstract}
This is the minimal abstract ever.
\end{abstract}

\section{Introduction}
Introduction here.

\section{References}
\nociteArticles{a1,a2}
\bibliographystyleArticles{unsrt}
\bibliographyArticles{Ref}

\nociteProceedings{c1}
\bibliographystyleProceedings{ieeetr}
\bibliographyProceedings{Ref}

\end{document}

I hope this could help.

Thanks and regards.

  • Welcome to TeX.SX! Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – Marco Daniel Nov 15 '13 at 12:16
  • 1
    As long as you use "old" bibliography styles the field doi isn't supported. An explanation is given here: tex.stackexchange.com/questions/36248/… -- Because you are starting with, you should switch to biblatex, which makes your live easier. – Marco Daniel Nov 15 '13 at 14:58
  • Thanks for the provided link. I found that I should use unsrturl instead of unsrt. However I couldn't find any replacement for ieeetr to support DOI. By the way, could you provide me equivalent code for the above tex so that I could switch to BibLaTex. I found that I should include \usepackage[backend=bibtex,style=numeric,sorting=none]{biblatex} in my tex but I don't know how to use it like multibib – user41086 Nov 15 '13 at 17:11
  • Splitting your bibliography depends on your needs. – Marco Daniel Nov 15 '13 at 18:41
4

As @MarcoDaniel has already pointed out in a comment, the bibliography styles unsrt and ieeetr are both quite ancient. In fact, neither bib style has been updated materially since about 1986, i.e., long before anybody conceived of using digital object identifiers (dois) and URLs in bibliographic references. Unsurprisingly, then, these two styles aren't programmed to recognize fields named doi and url. If a BibTeX style doesn't know about some fields, the rule is that their contents are ignored.

I suggest you consider using the unsrtnat and IEEEtran bibliography styles. The former style recognizes both doi and url fields; the latter recognizes just the url field, but not the doi field. Depending on your formatting needs, you may want to rename the doi field name to note and encase the contents of the doi fields in \url{...} wrappers -- at least for those entries that will be processed with the IEEEtran bib style. For added robustness, I suggest you load the natbib package with the option numbers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.