1

I'm using TeX Live 2012 on CrunchBang Linux (which is a derivative of Debian wheezy), and trying to get Adobe Source Sans Pro running, following this post: How can I use Source Sans Pro in Tex-Live 2012?. That is, I manually installed the package in local texmf (added mweights.sty as well), ran texhash and enabled the map.

Everything seems to have installed correctly, but when I try to compile a .tex file with pdflatex, I get this error message:

kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 SourceSansPro- Regular-lf-t1--base
mktexpk: don't know how to create bitmap font for SourceSansPro-Regular-lf-t1--base.
mktexpk: perhaps SourceSansPro-Regular-lf-t1--base is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.
!pdfTeX error: pdflatex (file SourceSansPro-Regular-lf-t1--base): Font SourceSansPro-Regular-lf-t1--base at 600 not found

I have searched for a similar issue, but didn't find anything mentionning this, so I suppose it's something in my configuration.

Could someone help me to see what I have done wrong?

closed as off-topic by Paul Gessler, Masroor, ChrisS, Guido, Przemysław Scherwentke Feb 9 '15 at 4:31

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    The error means the font was not completely installed. The most likely problem is expressed in the third line of the error message. Did your run updmap after your manual installation to enable SourceSansPro.map? – Dan Nov 15 '13 at 19:57
  • I ran sudo updmap-sys --enable Map=SourceSansPro.map, with the following output (when I run it now): updmap is using the following updmap.cfg files (in precedence order): /etc/texmf/web2c/updmap.cfg /usr/share/texmf/web2c/updmap.cfg /usr/share/texlive/texmf/web2c/updmap.cfg /usr/share/texlive/texmf-dist/web2c/updmap.cfg /etc/texmf/web2c/updmap.cfg unchanged. Map files not recreated. updmap: Updating ls-R files. SourceSansPro-Regular-lf-t1--base appears not to be missing from the map file, and the files it points to are present as well. – gingko Nov 16 '13 at 11:34
  • If you extracted the package to ~/texmf you might want to try running updmap --enable Map=SourceSansPro.map (as yourself). – Silke Nov 16 '13 at 15:05
  • @Silex: I installed the package in /usr/local/share/texmf. And running updmap (and not sudo updmap-sys) resolved everything. Strangely enough, I had tried to install another font (EBGaramond) and had the same problem. Running updmap --enable Map=SourceSansPro.map, as user, resolved also the mapping problem for EBGaramond. Thanks. – gingko Nov 16 '13 at 15:59
  • 4
    I'm voting to close this question as off-topic because it was a highly localized issue resolved in the comments. – Paul Gessler Feb 9 '15 at 2:35