4

Although I was glad to discover that biblatex integrates with babel for bibliography formatting, I might have found a bug that prevents it to work with idem (not ibidem) entries. Same goes with biblatex-dw (e.g. footnote-dw style), verbose*, historian and probably with any biblatex style. I keep getting a space before punctuation in citations managed with the idem tracker although the collins* bib entries have langid = {english}. Is there a workaround against this or should it be reported as a bug? Thanks.

I think I am up do date with biblatex version 2.8.

Example with style=historian,

\documentclass[french]{article}

\usepackage{filecontents}
\begin{filecontents}{file.bib}
@BOOK{collinscha,
  title={Changing Order: Replication and Induction in Scientific Practice},
  publisher={University of Chicago Press},
  year={1992 [1985]},
  author={Harry Collins},
  edition={New},
  langid={english}
}

@BOOK{collinsoth,
  title={another book title with same author},
  publisher={na},
  year={9999},
  author={Harry Collins},
  langid={english}
}
\end{filecontents}

\usepackage[T1]{fontenc}
\usepackage[latin9]{inputenc}
\usepackage{verbatim}
\usepackage[english,ngerman,frenchb]{babel}
\usepackage{csquotes}
\usepackage[style=historian,backend=bibtex8,autolang=hyphen]{biblatex}
\DefineBibliographyStrings{french}{namedash={---------}}
\addbibresource{file.bib}

\begin{document}
\cite{collinscha}.

\cite{collinsoth}.

Formating error: see how babel french made-up a space before the colon.

\cite{collinscha}.

\printbibliography
\end{document}

gives,

enter image description here

Example with style=verbose-trad1,

\documentclass[french]{article}

\usepackage{filecontents}
\begin{filecontents}{file.bib}
@BOOK{collinscha,
  title={Changing Order: Replication and Induction in Scientific Practice},
  publisher={University of Chicago Press},
  year={1992 [1985]},
  author={Harry Collins},
  edition={New},
  langid={english}
}

@BOOK{collinsoth,
  title={another book title with same author},
  publisher={na},
  year={9999},
  author={Harry Collins},
  langid={english}
}
\end{filecontents}

\usepackage[T1]{fontenc}
\usepackage[latin9]{inputenc}
\usepackage{verbatim}
\usepackage[english,ngerman,frenchb]{babel}
\usepackage{csquotes}
\usepackage[style=verbose-trad1,backend=bibtex8,autolang=hyphen]{biblatex}
\addbibresource{file.bib}

\begin{document}
\cite{collinscha}.

\cite{collinsoth}.

Formating error: see how babel french made-up a space before the colon.

\cite{collinscha}.

\printbibliography
\end{document}

gives,

enter image description here

  • Hmm, the first thing to try is pulling biblatex 2.8 from Sourceforge again - there was a flurry of fixes just before the TL release for some spacing issue like this and I'm still not completely sure if they all made it into the version pulled into TL. – PLK Nov 18 '13 at 8:15
  • what is the question? It seems to me that the space bifore and afferma the colon is part of french typography. – Guido Nov 18 '13 at 8:15
  • In fact, yes - if you remove all of the biblatex commands from the MWE, you still get the space ... – PLK Nov 18 '13 at 8:19
  • Of course it's normal for babel french to add a space. French is the default document language here. However it shouldn't do that on langid={english} entries (works for the first citation, not the idem one). That's the point. – elge Nov 18 '13 at 8:24
  • @PLK, thank you for the information. I overwrote the miktex 2.9 root dir content with the package I just downloaded from sourceforge (the 2.8 tds one) and launched a new TexWorks instance. I hope that is fine. But there is unfortunately no change in the result. – elge Nov 18 '13 at 8:34
4

This isn't a bug. The issue is that verbose drivers use the bibliography drivers for the citations. The bibliography driver obeys the langid (given suitable autolang and language option settings). However, idem citations don't use the bibliography driver and so don't pick up the langid setting since normal, non-verbose citations can't yet be localised. You'd have to wrap the idem citation in a babel language environment to work around this.

Language switching for citations is implemented in an experimental biblatex branch - I tested it with your example and it fixes the issue. I will see about rolling this feature into biblatex for the 2.9 release.

  • Just to be sure: A feature similar (at least) to tex.stackexchange.com/questions/21204/… will be implemented? – lockstep Nov 19 '13 at 13:30
  • 1
    I fact it is exactly that feature. There will be language=autocite and language=autobib (the default) with language=auto setting both. – PLK Nov 20 '13 at 7:29
  • Please try the 2.8a biblatex in the DEV folder on SourceForge. Look at the new values for the language option in the PDF doc. Basically, just try with language=auto. – PLK Nov 20 '13 at 15:40
  • yes, it works now. A temporary workaround for me would have been to \selectlanguage{english} before idem citations, but this is all fixed with 2.8a. Thank you very much. – elge Nov 20 '13 at 17:36
  • I wanted to mention - the 2.8a you downloaded was actually a mislabelled 3.0 experimental version. I have corrected this - you probably should get 2.8a again to make sure you have the right version. – PLK Nov 22 '13 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.