5

I'm using AUCTeX version 11.86 in GNU Emacs 23.2.1 in Windows 7, and I've just updated MiKTeX from version 2.8 to 2.9. How do I tell AUCTeX to use version 2.9 rather than 2.8?

A similar hypothetical question would be: if I had both MiKTeX and TeX Live, how would I tell AUCTeX which one to use?

The AUCTeX manual says

Should you need to change the executable names related to the different engine settings, there are some variables you can tweak. Those are TeX-command, LaTeX-command, TeX- Omega-command, LaTeX-Omega-command, ConTeXt-engine and ConTeXt-Omega-engine.

but I don't know how to do that (I'm not even sure it's the right thing to do) because my knowledge of Emacs is very superficial.

1 Answer 1

1

To set a variable in Elisp you use the setq function like this:

(setq TeX-command "/usr/local/share/special/bin/tex")

(The AUCTeX manual should give you information about what each variable should be set to.)

If you put the setq commands (one for each variable you want to set) into your emacs init file (~/.emacs for a Unix like OS) then those settings will be used every time you launch emacs.

1
  • Thanks for your answer. The problem was that I didn't know which variable(s) to set. I got it working by editing the path in Windows.
    – mark999
    Jan 12, 2014 at 7:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .