2

I'm trying to skip my parskip and linespread settings for all of my \chapter definitions.

Here's my complete example:

\documentclass[12pt,a4paper,oneside,]{scrreprt}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\inputencoding{utf8}
\usepackage{helvet}
\usepackage{mathpazo}

\usepackage[parfill]{parskip}
\linespread{1.5}

\begin{document}

Some text.

\chapter{Der positive Wandel – von den Neunzigern bis Heute}
\label{derpositivewandelvondenneunzigernbisheute}

The next paragraph starts.

\end{document}

… and the compiled output:

example

… what I want is a spacing like this:

ideal

Here's a list of my failed attempts

What all of these have in common is that they are not the solution or that I applied them completely in the wrong way.

I tried to rewrite the chapter via \renewcommand but failed… obviously something went wrong.

Inspired by this I also tried \newcommand\chapter[1]{\par#1\par\vspace{-\parskip}} which was as faulty as the one above.

My next try was this:

\newcommand\std@startsection{}
\let\std@startsection\@startsection
\def\@startsection{\renewcommand*\baselinestretch{1}\std@startsection}

Again, it didn't work. Just like this didn't work:

\makeatletter
\patchcmd{\@chapter}
  {\chapter{lof}}
  {\chapter{loa}{\protect\addvspace{10pt}}\chapter{lof}}
  {}{}
\makeatother

Or this:

\renewcommand\chapter
{\vspace{1.725\baselineskip plus 3\baselineskip minus .192\baselineskip }}
1
  • Do not use the »parskip« package. Read about the parskip option for the document class in the »KOMA-Script« user guide and give it a corresponding value. For the inter-line spacing use the »setspace« package and read something about "deadly sins" in »l2tabu«. Commented Nov 21, 2013 at 21:23

2 Answers 2

1

You don't need to patch \chapter or \@makechapterhead. Simply add your command to the font command:

\documentclass[12pt,a4paper,oneside,parskip=half-]{scrreprt}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\usepackage{helvet}
\usepackage{mathpazo}

\usepackage{setspace,lipsum}
\doublespacing %to see better the difference

\makeatletter
\addtokomafont{sectioning}{\setstretch{\setspace@singlespace}} 
%or only chapter instead of sectioning
\makeatother
\begin{document}
\chapter{Der positive Wandel – von den Neunzigern bis Heute}
\label{derpositivewandelvondenneunzigernbisheute}

{\Huge\bfseries\sffamily Der positive Wandel – von den Neunzigern bis Heute\par}

\lipsum[1]The next paragraph starts.

\end{document}
0
2

setspace is the best solution for manipulating the linespread (see also @ThorstenDonigs comments). The following solution patches \@makechapterhead relying on setspaces \singlespacing macro.

\documentclass[12pt,oneside]{scrreprt}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
  \inputencoding{utf8}
\usepackage{helvet}
\usepackage{mathpazo}
\usepackage{lipsum}
\usepackage{setspace}
  \onehalfspacing
\let\KOMA@makechapterhead\@makechapterhead
\renewcommand{\@makechapterhead}[1]{%
\begingroup
\singlespacing
\KOMA@makechapterhead{#1}
\endgroup}

\begin{document}

\chapter{Der positive Wandel – von den Neunzigern bis Heute}
\label{derpositivewandelvondenneunzigernbisheute}
\lipsum

\end{document}
1
  • Thanks for your solution (which by the way also worked). I read on parskip in the provided link by Thorsten but I guess I'll have to dive into LaTeX a bit more before I fully comprehend it (I just started three days ago). I choose Ulrike's version because it felt more concise.
    – patrick
    Commented Nov 22, 2013 at 11:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .