4

I'm having trouble getting the entire bibliography to show up when using \nocite{*}.

Here's an example:

\documentclass{article}

\usepackage{biblatex}

\begin{filecontents}{test.bib}
@ARTICLE{Doe2009,
author = {Jon Doe},
journal = {Transactions on Stuff},
month = 03,
number = {3},
pages = {1--11},
title = {{Example 1}},
volume = {5},
year = {2009}
}

@ARTICLE{Doe2010,
author = {Jon Doe},
journal = {More Transactions on Stuff},
month = 05,
number = {4},
pages = {1--11},
title = {{Example 2}},
volume = {7},
year = {2010}
}
\end{filecontents}

\addbibresource{test.bib}

\begin{document}

\section{Test}

%\cite{Doe2010}

\nocite{*}
%\nocite{Doe2009}
\printbibliography

\end{document}

The bibliography won't show up at all for me when it is like this. However, if I cite something in the document, for example I place \cite{Doe2010} somewhere in there, the entire bibliography will then print. Or if I add \nocite{Doe2009} the entire bibliography will also print. What am I missing here? Why won't \nocite{*} work on its own?

Update: I am using MiKTeX 2.9 with latest updates and TeXstudio.

enter image description here

closed as off-topic by Guido, Przemysław Scherwentke, Thorsten, Marco Daniel, m0nhawk Nov 23 '13 at 8:52

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    The code you gave works perfectly for me. – Guido Nov 23 '13 at 1:43
  • 4
    This question appears to be off-topic because it is not possible to replicate the problem. The MWE works correctly. – Guido Nov 23 '13 at 4:27
  • @Guido I suspect it is my setup then. I've updated my question with some additional info. – Steven Bach Nov 23 '13 at 4:30
  • Try to remove all auxiliary file (.aux, .bbl, .log) and try to compile again. Also try from the command line. – Guido Nov 23 '13 at 5:03
  • @Guido Removing the auxiliary files didn't work. However, I switched programs and used Texmaker instead. The default setting of PdfLaTeX + View PDF gives the same result. But if I switch it to PdfLaTeX + Bib(la)tex + PdfLaTeX(x2) + View PDF it will work! I couldn't figure out how to do that in TeXstudio so I'm going to stop using it. That said, I still don't completely understand these build commands/order and what they mean (specifically why PdfLaTeX is run again after and why twice). I would greatly appreciate it if you could explain it so I can educate myself. – Steven Bach Nov 23 '13 at 9:50

Browse other questions tagged or ask your own question.