1

I'm using TeXstudio as my LaTeX editor in combination with MiKTeX. At first I had the AltGr+F issue, but I fixed it, but there is another issue (bug?) that's bothering me and I'm wondering if it's just me or does anybody else has the same issue.

When I'm writing equations, and I want to add a superscript, when I type AltGr+3 (which is ^ sign) it often happens that TeXstudio just doesn't pick up on it, and I need to press AltGr+3 10 times before I get ^, and that is pretty frustrating when I'm typing (more frustrating since my thesis is in the field of general relativity which has tons of indices, upper and lower).

Is it just me or is this a widespread issue? If so how to fix it?

  • There are shortcuts for sub- and superscript, Ctrl + Shift + D (for down) and Ctrl + Shift + U (for up), you could use those instead. Edit: you can also change these, in Options --> Configure TeXStudio --> Shortcuts. – Torbjørn T. Nov 23 '13 at 9:45
  • Yeah, but these are kinda easy to type, that is I'm used to type it this way :\ (convenience argument :D). I guess I could change it, but I'm interested to see if I'm the only one with this issue. – dingo_d Nov 23 '13 at 9:49
  • This may also be a bug in QT. On a Norwegian keyboard, I am not able to write ´, (reach by AltGr+´) so the accent over several characters is not possible to write, for example é and á, which are often used. – Sveinung Nov 23 '13 at 10:01
  • Go to preferences -> shortcut, and try to give to a command the shortcut AltGr+3. If it was already in use (as I suspect), you'll get a warning. Just suppress this shortcut and the expected behaviour should come back. – Clément Jun 3 '15 at 10:09
  • What is "the AltGr+F issue" and how is it connected to the question? – valid Jun 20 '15 at 15:07
1

Try to remove (or add, if it is missing) the check in Options > Configure TeXstudio > Auto Complete Common Prefix

If it helps, remember to click Options > Save Current Settings

For me this helped for my different circumflex problem: I have circumflex ^ at Shift-umlaut (Shift-¨), but when I typed it, the cursor moved before the ^ and hence typing ^2 produced 2^ before I removed the check. This might help in other prefix problems too, to make prefices behave normally. If not, maybe try to Google for other prefix settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.